[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Non-english keyboard settings

Hello.
I’ve installed whonix OS. And I need to change keyboard layout language to Russian.
I tried to change language in system settings (reconfigure locales), but it didn’t help me.
I followed this instruction without result what I need

(1) Open a terminal. (For example: Konsole)

Start menu -> Applications -> System -> Terminal.

(2) Reconfigure locales.

sudo dpkg-reconfigure locales

(3) You will see the list of enabled and available locales. You need to leave only two of them: the English and the Russian. They are as follows:

en_US.UTF-8 UTF-8 ru_RU.UTF-8 UTF-8

Untick/disable all other locales if they are enabled, because if you have other Russian locales enabled you will get ??? (questions) characters instead of the Russian letters while typing in the terminal/konsole.

(4) Reboot Whonix-Workstation for the made changes to take effect.

Are there any another tutorials about it?
Thanks.

As per https://www.whonix.org/wiki/About#Based_on_Debian there should be other guides on third party web sites that equally apply.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]