No sound in guest [SOLVED]


My sound works 100% on my host. I have turned the volume all the way up on the guest, but there is still no audio. I’ve tried both youtube videos and local media in VLC. I’ve tried switching to ac97 with no luck.

EDIT: I followed the advice of HulaHoop and installed KDE instead of XFCE. The sound now works. Thanks! :blush:

EDIT again: I have found that sound also works in XFCE, but only if you install XFCE + Debian Desktop Environment in the installer. If you install initially without any GUI, and then manually install the xfce4 package afterwards, sound in KVM doesn’t work for some reason, even after installing all the sound related packages.


What host and DE are you running?

Are sure the same happens without Apparmor profiles installed (in the guest)? Please check this first as they can block access to the sound device.

Don’t switch to ac97. Its a very old device that could have security problems.


OK check that you don’t have this settings enabled (shouldn’t be by default).

Audio -> Audio Devices -> Select anything but “Discard all samples”


My host is Debian Stable with xfce, guest is standard Whonix Workstation with KDE and testing repo. I have tried disabling AppArmor and the sound still doesn’t work.

Where are these settings? I can’t find them.

EDIT: I found the settings in VLC. It’s set to default. And the no sound problem is not just in VLC, it’s the whole system.

When I launch a media file in VLC through the terminal I get the following message:

pulse audio output error: PulseAudio server connection failure: Connection refused


I have tried downloading a clean whonix workstation and only using the stable repo. Still have no sound. The error message in VLC is the same: Connection refused.


Can you check if there is a volume slider for “virt-manager” in the volume taskbar panel on the host? Make sure it exists and is not muted.

My next suggestion is to install another DE like KDE and see if sound works.


Volume slider for virt-manager does not exist. I’m gonna try switching to KDE and see if that works.