[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

No Route To Host, General Socks Failure when connecting to bridges


#1

I have setup torrc to connect to bridges before connecting to tor, however, when I run “arm”, I can see that the error when connecting to the bridges is “General Socks Failure”. When I try to telnet to the bridge on the specified port, I get, “no route to host”. The interesting thing here is that when I remove the bridges, and connect to tor directly, tor is able to connect…

Any ideas whats going on here?


#2

Hi jkygtiflug

Please see “Edit” at bottom of post.

Since there is no connection to Tor this requires disabling stream isolation and running command under user clearnet. But this might not be a benefit here since Tor is able to connect without bridges. Just a reminder user clearnet runs over clearnet.

https://whonix.org/wiki/Stream_Isolation#Deactivate_Stream_Isolation

This is a good example using curl to debug.

https://whonix.org/wiki/Dev/anon-ws-disable-stacked-tor#Debugging_with_curl

With bridges configured can you please run.

sudo -u debian-tor tor --verify-config

Output should contain.

Configuration was valid

Do you have seccomp configured. Meaning do you have Sandbox 1 configured in your torrc? If so please remove that configm as seccomp and bridges are not compatible.

https://whonix.org/wiki/Bridges#Connection_Issues

Try using a (private) (obfuscated) bridge that uses port 80 or 443 , as these ports are mostly used for web browsing and therefore usually unblocked.

You may also want to try new bridges even if you are already using port 80, 443 bridges. If the new bridges don’t work try connecting at a later time since Tor network congestion could also be causing this.

Edit: (Do this first) Lastly, try to simplify your setup. Remove everything that is not necessary. For example, any VPNs proxies etc. Then try bridges.


#3

Thank you for your reply…

I am not using any VPNs or proxies

Since there is no connection to Tor this requires disabling stream isolation and running command under user clearnet . But this might not be a benefit here since Tor is able to connect without bridges. Just a reminder user clearnet runs over clearnet.

I have verified the bridges are in fact valid, and capable of being connected to

sudo -u debian-tor tor --verify-config

I ran the command, and it said Configuration was valid.

Do you have seccomp configured. Meaning do you have Sandbox 1 configured in your torrc? If so please remove that configm as seccomp and bridges are not compatible.

I did not have this setting, and I checked all of the torrc and tor conf files on the machine

https://whonix.org/wiki/Bridges#Connection_Issues

I have reviewed the issues on this page, and none apply to my situation

Try using a (private) (obfuscated) bridge that uses port 80 or 443 , as these ports are mostly used for web browsing and therefore usually unblocked.

but acknowledged.

You may also want to try new bridges even if you are already using port 80, 443 bridges. If the new bridges don’t work try connecting at a later time since Tor network congestion could also be causing this.

I was able to connect via clearnet, so I dont think this is the problem…

The error in arm is “general SOCKS server failure”, sorta vague, so im not sure what the issue is

Does the whonix-gateway work out of the box with tor bridges?


#4

Also don’t rely on arm. (https://www.whonix.org/wiki/Tor_Controller#Arm_FAQ) Better:


#5

Hey Patrick, again, thank you for the links =]