[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

No internet connection on Whonix

I have just installed Whonix onto Qubes 3.0 and it appears that my connection to the internet is stuck inside of sys-net, so to speak. When I go to the network connection it is within sys-net. How do I allow internet access in to my Whonix VMs?

Thank you

Network connection is always “stuck inside” sys-net.

Qubes VM Manager, click Whonix-Gateway, VM Settings

Compare to steps 5, 6 here:

Traffic flows like this:
Workstation -> Gateway -> sys-firewall (if present) -> sys-net -> internet

Being new to the subject I was sure in making this topic that my answer might seem self-obvious or simple. However, I have followed all steps as directed at https://www.whonix.org/wiki/Qubes/Install yet when the privacy browser is launched, in the domain anon-whonix (I named everything exactly as in the tutorial), which is in the whonix-ws template, “Unable To Connect” displays in the browser, even though sys-net is connected to a network. All settings are exactly as configured in the tutorial. Upon applying the settings as instructed, does Whonix, normally, connect to network automatically or are there some additional step(s)?

Thank you, and pardon my ignorance

Please confirm all of these VMs are up and running. Launching Browser should automatically launch all of these VMs.

It can take a few minutes after initial startup for Whonix Gateway to bootstrap Tor. There is nothing else you need to do. To make sure Gateway is connected, go to Qubes Menu -> sys-whonix -> whonixcheck.

You can also run whonixcheck in the Workstation. Qubes -> anon-whonix -> whonixcheck to make sure everything is operational.

Ok,
I’ve run whonix-ws and whonis-gw, both needed to be updated, and they have now both been updated. I run checks on both, both are update to date and working, and both connect to the Tor network. I’ve also checked sys-whonix and updated it also. Then when I run a check on anon-whonix I get:

"ERROR: Tor bootstrap result:
Tor’s Control Port could not be reached!
Troubleshooting:

  • Confirm that Whonix-Gateway is running.
  • Run whonixcheck on Whonix-Gateway and form success.
  • Rereun whonixcheck here in this Whonix-Workstation

(Technical information:)
(Code: 255)
(tor_boostrap_timeout_type: none)
(tor_boostrap_status: Socket error: )
(check_socks_port_open_test: 7)
(Tor Circuit: not established)"

Then I just check whonix-gw again and got an error with it as well:

"ERROR: Tor Boostrap Result:
Tor’s Control Port could not be reached!
Please report this Whonix bug!

(Technical information:)
(Code: 255)
(tor_boostrap_timeout_type: none)
(tor_bootstrap_status: Socket error: [Errno 113] No route to host(
(check_socks_port_open_test: 7)
(Tor Circuit: not established:

Any ideas?

Update: it appears that dom0 also needs to be updated. Will check back if that resolves things.

Update 2: I am downloading the dom0 update, and halfway through got this message:
"[Dom0] Houston, we have a problem…

Whoops. A critical error has occurred. This is most likely a bug in Qubes manager.
libvirtError: Cannot write data: Broken pipe at line 1268
of file libvirt.py."

It also gives the option of “Details” which gives a larger report.

I closed out of it, tried updating again and now it says that there is no network connection available (despite being connected fully to a network)

“There is no network connection available.
Please check your connection settings and try again.”

I also tried updating dom0 from terminal but it says "No new updates available"
I can’t tell if that means there are none available because it isn’t connecting to the network, or whether it is indeed up to date despite this “Updates pending!” icon in Qubes VM manager
Since fedora-21 TemplateVM also has this “Updates pending!” icon I am curious how to update it via terminal, I couldn’t find that on the Qubes website, or that not necessary/a good idea? Because when I try to update fedora-21 via Qubes VM manager I get that same pipe 1268 error message.

Hmm…

Update 3:
Restarted computer.
Dom0 no longer says it needs to be updated.
whonix-gw comes clean and up to date as per check.
checked whonix-ws and it is also up to date and good
Then I check sys-whonix and it tells me that whonix-gw needs to be updated, which I thought was odd because it just came back as up to date. But I tried to update it and nothing was installed, upgraded, removed or otherwise.
Then I shut down whonix-gw as per instruction, turned it back on, checked sys-whonix and it still tells me it needs to be updated, which is bs.
Restarted my computer and sys-whonix has no problems now.
Checked whonix-gw – good
Checked whonix-ws – good
And yet when I check anon-whonix it is the same old error message telling me to run whonixcheck on whonix-gate way, Code 255 etc.

Jeez

Can someone please help?

Not sure what to make of this or how to troubleshoot. Almost inclined to believe that you’re using an unstable WiFi connection…

First thing that I notice from your posts is that you don’t have an understanding of how TemplateVMs work. This is a fundamental concept to Qubes and is required to make any sense of the OS. Explained here:


It’s been awhile since I installed 3.0 per the instructions so I can’t confirm if new bugs exist or not. No reason why installing and updating should be a problem though.

You can try again (reinstall from scratch):

  1. Follow Install / Update directions
  2. Update TemplateVMs: boot, update, shutdown. No need to test for connectivity or do anything else with them.
  3. Update dom0
  4. Reboot
  5. Make sure sys-net, sys-firewall, sys-whonix are running
  6. Run whonixcheck in sys-whonix. If error, run it again. Give it 5 mins to connect to Tor.
  7. Run whonixcheck in anon-whonix.

Other option is to go to qubes-os.org and download / install Qubes 3.1 rc3. It has Whonix integrated by default but not documented yet. Should be blessed stable in a matter of weeks.
Or wait for someone else to help you.

Thank you for your help and tips, I will try the options you recommend. As per my lack of knowledge I make no claim to the contrary but I do indeed at least understand TemplateVMs to a basic degree whatever my skewed vocabulary might imply. Although I do agree that the more thorough ones knowledge the less likely they are to encounter problems and higher is their ability to resolve them, in this case I’ve followed all instructions very carefully and have refrained from doing anything I don’t understand, so I don’t think my lack of knowledge has contributed to this issue. I’ll likely reinstall from scratch or try 3.1 rc3.

Glad you could help

libvirt / Qubes VM Manager (QVMM) error messages are Qubes, not Whonix issues. Best directed at the native Qubes support channels.

The update available icon not going away even if it should is a known Qubes issue that has a ticket in Qubes issue tracker.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]