[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

No connection in kvm


#1

Hello
When I run whonix for the first time Tor bootstrap failed and with sudo apt-get update give me error when tried to connect to ftp.us.debian, deb.project.tor, mirror whonix.de, security.debian.org "something wicked happened resolving …(-4 non recoverable failure in name resolution). Tor is active (running) then I think that there is problem in kvm though I have done all the steps in the guide. Tor works on the host.

Thank you for the help


#2

Hi

Do you live in a censored area? (If yes they could be blocking your connection and you will need a bridge)

Is your host’s clock set correctly? (An incorrect clock prevents Tor from bootstrapping)

Make sure KVM’s / QEMU’s default networking is enabled and started:

virsh -c qemu:///system net-autostart default

virsh -c qemu:///system net-start default


#3

Hi

I don’t live in a censored area
Yes, my clock is correct
Default networking is enabled

One thing that I noticed is when start vm there is a line ‘a start job is running for LSB: raise network interface’’ takes more than 1 minute


#4

Good day,

did you verify the images after downloading?

Have a nice day,

Ego


#5

Hi
Yes
I moved it from a partition to another. Did it cause any problems?
I saw this command that I didn’t run
sudo ln -s /etc/apparmor.d/libvirt/TEMPLATE.qemu /etc/apparmor.d/libvirt/TEMPLATE.kvm
Does it fix?

Thank you


#6

If you are on Debian stable run: sudo ln -s /etc/apparmor.d/libvirt/TEMPLATE.qemu /etc/apparmor.d/libvirt/TEMPLATE.kvm

to resolve an Apparmor bug.

Its highly recommended to put the image files in the documented folder to avoid conflicts with MAC or security problems.


#7

Hello
When I run for the second time
virsh -c qemu:///system net-autostart default
Network default marked as autostart

while with virsh -c qemu:///system net-start default
error: failed to start network default
error: requested operation is not valid: network is already active

The same thing with virsh -c qemu:///system net-autostart whonix and virsh -c qemu:///system net-start whonix

Doesn’t it show network is already active also in net-autostart?

Thank you


#8

You are seeing these errors because these two networks have been successfully started and set to autostart.