[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Newest update breaks gateway permanently

In the gateway (vmware), in terminal i input:

upgrade-nonroot

Results in freezing on the line:

Virtualbox guest additions: building the modules for kernel 4.19.0-16-amd64

I gave this many hours but the entire vm was frozen. I copied over a backup gateway vm i had and tried again, same result. When i restart the gateway vm after it freezes the startup sequence appears different, it scrolls fast and i can see many {FAILURES] in red letters. Tor will not work, there is an X where there should be that padlock in the upper right corner. It says there was a critical error and tor service could not load and it is often the line β€œdisable network 1” that i have to find in torrc and remove, but there is no such line in torrc.

If i try to reload tor gui i get this message:

job for tor@default.service failed because the control process exited with error code

If i try to reload tor service i get this message:

Process 3612 Execstart=/usr/bin/tor --defaults-torrc /usr/share/tor/tor-service-defaults-torrc -f /etc/tor/torrc --RunAsDaemon 0 (code=exited, status=1/FAILURE)

After copying over a backup gateway vm i instead issue this command in terminal and for now it works:

sudo apt-get upgrade tor

edit: since this may be vmware related i am using vmware version 5.2.42_ubuntu r137960. This is the only version available for my distro:
NAME="Zorin OS"
VERSION="15.3"
ID=zorin
ID_LIKE=ubuntu
PRETTY_NAME="Zorin OS 15.3"
VERSION_ID="15"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

since this may be vmware related i am using vmware

VMware is not recommended and unsupported and no support going to be done for it.

So you need to use Virtualbox,KVM,Qubes/Xen as these are officially supported.

Wrong, i said vmware by mistake, i was confused by the similar names of these generic vm software. Its clearly posted i put my virtualbox software number in the description. This latest update breaks the gateway because of virtualbox additions which i do not have installed, so i dont know what this problem is and you should address it instead of finding some minor flaw in my description.

Please edit your original question.

See, specifically:

Whonix XFCE for VirtualBox users: RAM increase required

Generaly:

1 Like

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]