[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

New whonix version breaks GPG

I upgraded my workstation successfully to the newest version. Its working fine as i can see, but i noticed the little padlock icon in the upper right that was my KGPG (gpg frontend) software was missing. I tried to load it from the applications menu and it wont load. I have tried sudo apt-get update, sudo apt-get upgrade, it does not have any updates.

I have installed seahorse (via terminal apt-get install) to see if it was kgpg specific and seahorse does not even show in the applications menu after its installed. I have tried to install GPA, XAP, and pyrite but apt-get does not recognize them, despite the first two being listed on the GnuPG website as frontends for linux GPG. I also tried using gpg4usb which was working a year ago when i last used it, the software loads but it will not recognize or import any keys.

If anyone has a working solution please advise, i need gpg for secure communication.

edit: i installed kleopatra and it does not show in my applications menu either. I dont know any other gpg frontends.

There is only one gpg software that works its gpa privacy assistant. It has some of the features of other software but its very cumbersome to use, importing and exporting keys must be done with a textfile instead of clipboard and it fails decrypting some various pgp software encrypted blocks due to poor compatibility (does not force decrypt or provide error message with decrypted data). It looks like the developers arent interested in keeping basic software functioning, instead forcing us to change our entire environment to suit them breaking everything in the process.

GPA (preinstalled) working from my end.

1 Like

OpenPGP (GnuPG Frontend)

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]