Network problem in nested KVM virtualization

I set up the Whonix VMs according to these instructions, everything turned out well - whonix.*org/wiki/KVM
After that, I tried to install a nested virtual machine inside Whonix Workstation, also using KVM. They work well, but there is no internet. I’ve tried Kicksecure, Whonix, Debian.
If you do the same thing through Virtualbox, then the Internet in the nested machine works well

If you are trying to run a vm in the Whonix-Workstation, that’s not going to work because it doesnt have internet of it’s own.

It’s using the gateway to establish each connection. I’m pretty new to this so I don’t know how exactly you could solve that problem, but I do know what the problem is.

You’d have to get the nested vm connected to the outer gateway somehow.

I assume the similar IP addresses would cause a conflict so change the nested Gateway’s external NIC to use the default network and make sure DNSMASQ is also installed on the outer Workstation VM because it is a hard requirement for libvirt on Debian

1 Like