Need help with putting proxy after Tor (documentation is outdated?)

I’ve read Connecting to Tor before a Proxy and googled for hours, yet I cannot make me → tor → proxy work.
I tried this: user@host:~$ UWT_DEV_PASSTHROUGH=1; TOR_TRANSPROXY=1; torbrowser
and a dozen other variations.

When I check proxy on the host it works well, but in the workstation it doesn’t. Any help?



This surely is a syntax error.

proof failing:

xxx=a ; env | grep xxx

vs proof working:

xxx=a env | grep xxx


Doesn’t hurt, but not required for Tor Browser.


That would only be required for socksifier proxification method. But as
documentation states, there is currently not known to work socksifier
proxyfication method for Tor Browser.

Get a fresh Tor Browser. (Because deactivating effects by
TOR_TRANSPROXY=1 has not been documented.)

Then try proxy settings method as per documentation.

EDIT: Sorry, posted too soon the first time.

Recently tested 3 Methods in documentation:

A. application proxy settings (foxy proxy):
tor browser: working
(using Preferences menu does not work)
iceweasel: working

B. proxifier (proxychains):
tor browser: not working (as stated)
iceweasel: working

C. transparent proxy (redsocks):
tor browser: working
iceweasel: working

This is new info to me. Thanks for updated docs!

@lammy I just added TOR_TRANSPROXY=1 to /etc/environment. Reboot.

EDIT2: /etc/environment method works best when using a dedicated workstation for proxy exits.
If running multiple browsers, either the command line method or editing the startup script is more appropriate.

EDIT3: Gah, since Foxy Proxy doesn’t support chaining of proxies, there’s still no way to exit from a proxy server using Tor Browser with TransPort disabled. Need proxychains to work for that.