[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Multiple Errors while Updating Gateway

Hey guys, thanks for working so hard in the service of privacy!
Unfortunately I’m experiencing a few errors and your docs made me a little paranoid, and i don’t know if I’m gonna be safe or not.
Here’s my situation:

  • running whonix on virtualbox on win7
  • using freshly downloaded images of v13.0.0.1.1
  • both imported into VB as described here:
    whonix.org/wiki/VirtualBox [sry can only put 5 links as new forum member]
    *only thing i changed was the gateways ram to 128mb as stated in the license agreement
    (sadly my notebook has only 2gb ram :disappointed: )
    now i wanted to update the gateway first, so i started its virtual machine:
  • swapfile is being generated, login as user, whonixsetup starts
  • hit “understood” 2times and then cancel since i’ve experienced some issues w/ the setup before (yes, i tried to update the gateway multiple times already)
  • enable the whonix repository by running:
  • next i manually edit /etc/tor/torrc:
  • uncomment “DisableNetwork 0” and save
  • run the whonixsetup again (just so i don’t miss anything):
  • “i’m ready to enable tor”,“ok”,“yes” ->“Tor should already be enabled”, “ok”->“Tor was successfully restarted”
  • whonixcheck gives one warning(“apt-get reports that packages can be updated”), then exits
  • after a reboot(just to be sure everything found it’s place and is loaded correctly) i start updating:
  • then:
  • “135 upgraded […] need to get 171mb of archives […] continue?”, “y”
  • downloads all 135 packages w/o any problems
  • then i get an “sda1: write same failed”-msg, but upgrade continues
  • next thing i noticed is a “failed to set capabilities”-msg for the file /usr/bin/systemd-detect-virt
    -and shortly after a dpkg error: “dpkg status database is locked by another process”; after this the upgrade exits: https://picload.org/image/rddrdlod/dpkgerror.png . . . [->5links]
  • now i do a reboot, cuz i hope it will at least partly load the newly updated packages
  • after login whonixcheck says i’m connected to tor and exits
  • since the strange exit of the update/upgrade, i run it again, first apt-get update, then apt-get dist-upgrade
  • “112 upgraded […] 10 not fully installed or removed […] need to get 0b/81,5mb of archives […] continue?”, “y”
    -again the “sda1”-msg (just a different number in front of it)
    -[a whole lot of unpacking]
  • then a wild hrtimer-interruption, followed by lots more of unpacking
  • next i get something about unknown media types, after which the upgrade freezes(or at least doesn’t log anything new anymore) for hours(8h+)
  • then the upgrade exits with this
  • reboot
  • now - even before logging into the user-account - i get this, and after the login i still get messages like that at random intervals…

anyone know what’s wrong?? how do i fix this? or is this nothing to worry about and i can go on to update the workstation?!

like i said, i’ve done this updating process multiple times, always starting with a clean image.
but the outcome was always like this (course of events was not always the same, but very similar. e.g. upgrade didn’t always freeze at that exact point, but always during the second upgrade)
hope i’ve included enough info for you to help me :wink:
thanks in advance.

https://www.whonix.org/wiki/FAQ#Am_I_compromised.3F

Perhaps it’s this one:

If you are affected, bad luck. There is no solution for this on this on the Windows platform.

So your only option would be trying a Linux host.

Also starting with terminal-only as a Linux beginner is probably non-ideal.

Short: Ignore. Has been discussed elsewhere. Please use the search function and search engine searches.

Not an error message. Happens to any Debian based operating system.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]