Missing pinentry package Whonix 14


The lack of the pinentry-qt4 package causes inexplicable decryption failures when viewing GPG messages in Thunderbird. Where do I add this to dependencies?

[SOLVED] GPG/PGP Key importing failed

Generally related (at least in terms of software):

  • 0brand had to install some package for his related tests on GPG key retrieval.

  • Clear there are some little bugs in this area in the stable release; might also relate to why that other guy couldn’t create a rev certificate in Whonix 14 (but worked in Whonix 13) etc. I forget where that thread is.


That was Debian, package dirmngr, we have it here:

pinentry-qt here already:

apt-cache show pinentry-qt4
Package: pinentry-qt4
Depends: pinentry-qt (>= 1.0.0-2)
 Pinentry is a program for secure entry of PINs and passphrases, from
 the GnuPG project.
 This package installs a symbolic link from pinentry-qt4 to
 pinentry-qt.  You should switch to using pinentry-qt instead.

The syntax using pipes |, i.e. pinentry-qt | pinentry-gtk2 | pinentry-curses | pinentry, should mean prefer pinentry-qt to satisfy the dependency but if any other packages pinentry-gtk2 | pinentry-curses | pinentry get installed that also satisfies the dependency.

Which one is installed by default?

dpkg -l | grep pinentry

What may be happening during the build process that another dependency pulls our non-favorite first. That would be a bug fixable in a new build but hard to fix for people who upgrade.


I did a package search on a default install and pinentry-qt is not there. Something must be preventing its install somewhere.


Output: pinentry-curses


Could you please create a ticket for this?




debootstrap (called by grml-debootstrap pulls pinentry-curses during Whonix build process.

+ debootstrap --arch amd64 --verbose --include=initramfs-tools,grub-pc,eatmydata,apt-transport-tor,python stretch /mnt/debootstrap.21865 http://ftp.us.debian.org/debian

I: Found additional base dependencies: dmsetup gettext-base gnupg-agent grub-common grub-pc-bin grub2-common initramfs-tools-core klibc-utils libapparmor1 libassuan0 libbsd0 libcap2 libcryptsetup4 libdevmapper1.02.1 libdns-export162 libeatmydata1 libelf1 libexpat1 libfastjson4 libffi6 libfreetype6 libfuse2 libgmp10 libgnutls30 libhogweed4 libidn11 libidn2-0 libip4tc0 libip6tc0 libiptc0 libisc-export160 libklibc libksba8 liblocale-gettext-perl liblognorm5 libmnl0 libncurses5 libnetfilter-conntrack3 libnettle6 libnfnetlink0 libnpth0 libp11-kit0 libpng16-16 libpsl5 libpython-stdlib libpython2.7-minimal libpython2.7-stdlib libseccomp2 libsqlite3-0 libtasn1-6 libtext-charwidth-perl libtext-iconv-perl libtext-wrapi18n-perl libunistring0 libxtables12 linux-base mime-support pinentry-curses python-minimal python2.7 python2.7-minimal ucf xxd

But I now have an idea how to fix it even for users who upgrade.



This should be done in all Whonix 14 repositories.