[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Make KVM work again after deleting whonix gateway .qcow2, with a new whonix gateway


#1

Due to space problems I was literally forced to delete whonix gateways disk.In my case the disk was Whonix-Gateway.qcow2

After that I simply downloaded whonix gateway for kvm again. I didnt do anything special, I extracted the .qcow2 file again started whonix gateway from kvm, and it simply worked again. I did once again all the start wizard of the first time to setup the gateway and it worked. For a few days.

Now due to power issues some day ago whonix gateway was interrupted during an update. However guess what: it was still working.
With sudo apt-get install -f / dpkg etc, I fixed up everything missed by the upgrade. No errors shown at all and everything was working.
Today the gateway stopped working. It was stuck at 80% of tor bootstrap. So, after rebooting and testing my connection 1000 times I said fuck it, i simply delete this qcow2 again and simply extract again the same file I used before.

And now whonix Gateway isnt working no more. Simply it gets stuck in tor bootstrap, at 5% and goes on and on. Doesnt move from 5%, simply it behaves like this new whonix gateway cant see the network.

I need someone to tell me how I can install again whonix gateway in KVM. Im migrating everything in a new OS, problem is that inside workstation I got some files I really need! And looks like internet is my only way out of there.

What I tried:

  • Testing TOR on host: working perfectly
  • Following again the installation steps in whonix wiki for KVM. I only get an error that tells me that whonix gateway already exists.

My original whonix gateway was actually whonix gateway 12. Now I have whonix gateway 13. And yes of course I verified the file after downloading it.

The list of files inside whonix’s folder:

  • Whonix_network-13.0.0.1.4.xml
  • Whonix-Gateway-12.0.0.3.2.xml
  • Whonix-Workstation-12.0.0.3.2.xml
  • Whonix-Gateway-13.0.0.1.4.xml
  • Whonix-Workstation.qcow2
  • Whonix-Gateway.qcow2
  • Whonix_network-12.0.0.3.2.xml

Originally Whonix-Gateway.qcow2 was Whonix-Gateway13.0.0.1.4.qcow2 or something similar, I renamed it cause KVM didnt read the new qcow2 file.

First time I did it, it really worked. Downloaded whonix gateway again, extracted, renamed, and voila. Now I have no idea on how to proceed. Any help is appreciated, even a link explaining a similar problem
Thank you.


#2

Assuming you just perform regular apt updates, how big did the image file get for you to delete it? I would expect this with the workstation VM

This is a problem I saw reported frequently. It has little to do with the underlying hypervisor because its invisible to the guest. A possible solution that’s not ideal is to reset Tor’s consensus files but that could leave you open to picking a malicious guard. I recommend making a clean snapshot of the GW before starting it for the first time and restoring it if things don’t work every time. Definitely faster than re-downloading the image.

@Patrick any suggestions? What is the usual fix for this?

This is unnecessary as moving the image to the libvirt folder renames it for you automatically.

I recommend checking the storage folder for gateway mutliple images that could have made their way there by mistake. Go to: Virtual machine Manager -> Edit -> Connection Details -> Storage.

I think its best if you start over one more time from a newly extracted image that you snapshot right after importing then give it a try.


#3

Well, try bridges?

Otherwise… That’s rather hard to debug. Could be either a legitimate Whonix bug. Or a virtualizer specific connectivity bug. Or network censorship.

You need to “UnWhonix”. Remove Whonix configurations until it’s like Debian.

https://www.whonix.org/wiki/Dev/Test

Then see if Whonix was the cause. Otherwise from there debug as per https://www.whonix.org/wiki/Free_Support_Principle i.e. by contacting various upstreams for help.

Realistically at the current state of Whonix development, users who run into such issues won’t be able to use Whonix. Best hope is waiting for a highly skilled user running into this issue, and successfully debugging it.