Lock screen not working on workstation

Anybody knows how to fix this bug? I would love to use whonix workstation but it’s not allowing me to lock the screen. When I hit “Lock screen”, nothing happen.

Please add more details:

which virtualizer/hypervisor you are using? which version of whonix? which DE?

Hi Dulc3Maria

This is not a bug. The sreen lock for Whonix VMs are not configured because there would be no security benefit. Anyone that has access to a running host (i.e. a machine on which a virtual machine runs) without its screen lock, would have full access to the Virtual machines whether or not the Whonix VM screenlock in enabled. Since Whonix is not a multi-user OS you should use Full Disk Encryption on the host.

Encrypted guest images (Whonix VMs) is experimental and Unsupported.

Note: If you still would like to configure screen the answer can likely be found as per: https://whonix.org/wiki/Support#Free_Support_Principle

Since Whonix is based on Debian, you might want to search how to enable screen lock in Debian. You might also have to disable auto-login. It will require editing this file.

In Whonix-Workstation konsole, run.

cat /etc/login.defs


To lock screen on the host:

1 Like

Hi sir. I’m using whonix workstation (xfce) on virtualbox under linux mint as host.

Amazing piece of knowledgement. Thank you so much sir it’s really helped me. My linux mint (host) if fully encrypted so I think I’m safe even without the lock screen then.

Hi Dulc3Maria

No problem, keep in mind that FDE is only a benefit when the Host is shutdown. So it is recommended that the host be shutdown if you intend to leave it unattended.


Thanks m8. If I lock my VM screen then lock my host screen too, it’s help in something?

Locking your VM screen will have negligible security benefits. If someone had access to the host without screen lock it would it would be simple matter to gain access to the VM. However, it can’t hurt to lock both VM and host if that is what you want to do.