[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Live-mode on host OS (debian 10)

The host system start in Live-mode.
The swap is not loading.
Swap file is not created (swap-file-creator)/
When starting guest-systems (other) in virtualbox, after a while the system freezes. No commands can be executed. Just a hard reboot.

Is there a connection between this event (freeze os) and the launch in live-mode?

If it does not free in persistent mode, then this could be the case.

How much (free) RAM does the host operating system have?

So you did boot in host live mode… Did you then start VMs in live mode or “persistent” mode?

When starting the host in host live mode it’s not really needed to start the VMs in live mode. I don’t think we currently make this clear in documentation. But perhaps starting VMs in “persistent mode” wouldn’t be really persistent since the host is already booted in live mode would help.

Related:

8 Gb

“persistent” mode

I see.
that’s what I do. I do not run in live mode

swap-file-creator does not run if live mode is detected.

I see
And with the usual start of the host, you can see
through the command

  • sudo swapon -s
    and
  • free -m ??

What exactly do I need to see in order to identify?

And in life mode, how to free memory manually?

sync; echo 1 > /proc/sys/vm/drop_caches`

sync; echo 2 > /proc/sys/vm/drop_caches`

sync; echo 3 > /proc/sys/vm/drop_caches`

So?

I don’t think there are any tricks for that. On that question, https://www.whonix.org/wiki/Free_Support_Principle applies.

Well, usual host optimizations might help. Such as installing a light desktoip environment and/or stopping services that aren’t required but taking RAM. (If there are any.)

Try to monitor RAM and see if it fills up. If that is even the issue. Try to see if RAM fills up before the freeze. You can monitor RAM usage with many tools, ksysguard comes to mind.

I’ll try earlyoom now
and I will monitoring.

Question: Why do I have / run / live / overlay - 4GB when running in live mode?
Fills up quickly.

As far as I know, this is expected behavior when booting in live-mode.

It may freeze because you didn’t launch the VM in live-mode. Try booting them in live-mode too.

See also:

and

https://phabricator.whonix.org/T914

This is normal. It can be modified with overlay-size kernel boot parameter in GRUB.

See:

man live-boot

overlay-size=SIZE

The size of the tmpfs mount (used for the upperdir union root mount) in bytes, and rounded up to entire pages. This option accepts a suffix % to limit the instance to that percentage of your physical RAM or a suffix k, m or g for Ki, Mi, Gi (binary kilo (kibi), binary mega (mebi) and binary giga (gibi)). By default, 50% of available RAM will be used.

1 Like

Thx for info

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]