[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Ledger not detected in VirtualBox on Linux

Hello,

I am trying to use Ledger + VirtualBox + Whonix and when I try to connect the Ledger to Whonix in VirtualBox settings, I get “No device available” message.

Version details:

  • Ledger Nano X, firmware and apps up to date
  • Host machine: Linux Mint 20.3, firmware and software up to date
  • Whonix version: 16.0.4.2, software up to date

Steps to reproduce:

  • Apply the udev rules needed for Ledger on Linux on both the host machine and the Whonix VM.
  • Shut down Whonix VM, restart host machine
  • Connect Ledger, enter Ledger PIN, open Monero app. Open Ledger Live and perform “genuine check” to make sure Ledger is detected, get confirmation that Ledger is genuine and connection is confirmed.
  • Open VirtualBox on host machine. Click “Settings” on Whonix VM in VirtualBox, go to USB, check “Enable USB Controller”, click “Add filter”
  • See error message “No device available”. Cannot proceed from here.

Any ideas about what the issue could be?

Maybe this helps?

(Whonix is based on Kicksecure.)

Could you try to reproduce this please in a Debian VM inside VirtualBox? As per https://www.whonix.org/wiki/Free_Support_Principle

Thanks for those links. I had previously followed as many of the steps as I could from the Ledger page when I ran into the issue reported here. I did not think to try a Debian VM in VirtualBox to see if the same issue happened. I will refer back to this Free Support Principle document in the future.

I had the same problem with the Debian VM, so it wasn’t a Whonix specific issue. This led me to search “USB through linux virtualbox”. I then found instructions that solved my problem. I will post the solution here in case anyone else has the same issue:

  1. Install VirtualBox Extension Pack.
  • Download extension pack on host machine, found here: https:// www. virtualbox. org/wiki/Downloads (without spaces – the forum software would not let me post the link un-altered)
  • Open VirtualBox
  • Click “File” → Preferences → “Extensions”
  • Click “Add extension” then find and select the extension pack you downloaded
  • Close VirtualBox after the extension pack is done installing
  1. Add your user to vboxusers group
  • On the host machine, open the terminal
  • Enter sudo gpasswd -a yourusername vboxusers replacing yourusername with your actual Linux user name
  • Log out of your Linux account, then log back in
  • Now you should be able to see your Ledger show up in the list of available devices in the VirtualBox Whonix USB settings

Great to hear!

This is probably optional.

related:
VirtualBox Oracle VM VirtualBox Extension Pack

This is probably very much required indeed for USB devices inside the VM.

VirtualBox installation instructions (Recommended VirtualBox Version for use with Kicksecure ™) contain this.

(Whonix is based on Kicksecure.)

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]