[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Kvm + whonix 11 slowness


#1

hi there , im using debian jessie with kvm + whonix 11. before when i was using the kvm it was on my old laptop and i thought the slowness from the laptop itself. now i have shifted my work on my new laptop to work on debian and i have installed kvm + whonix 11, but the suprising i have got the same thing. the whonix is very slow and freeze for few seconds and work again with slow performance and so on … i thought the cause is might be i should increase the ram and the processor so i have increased the GW to 1gb ram and the WS to 2.5gb ram and gave it 2 core processor = the same thing. also i have installed the nvidia graphical card reader on debian jessie thought the problem might be fixed but it was the same, what should i do to make it work properly ?

also is there any inhancements to these issues:-

1- tor browser start up page in whonix , whonix pic very messy (only in kvm).

2- the two black sides on the right and left of the screen when maximazing the window to fullscreen

c the photo:-


Ubuntu-Whonix(KVM) has delay when browsering webpages and typing letters
#2
i thought the cause is might be i should increase the ram and the processor so i have increased the GW to 1gb ram and the WS to 2.5gb ram and gave it 2 core processor = the same thing. also i have installed the nvidia graphical card reader on debian jessie thought the problem might be fixed but it was the same, what should i do to make it work properly ?

The vm specs are good enough and anything more would be a waste. The slowness you are feeling is because the virtualized graphics stack is not as good as can be and delays the image output. This will change when paravirtualized graphics (virgil3d) become part of KVM in Debian Stretch.

(I ship ws with 2 cores already doesn’t it appear when you first import the vm?)

1- tor browser start up page in whonix , whonix pic very messy (only in kvm).

Yes I saw it too and reported it but found it was KVM only. Its another problem with the graphics stack like I said.

2- the two black sides on the right and left of the screen when maximazing the window to fullscreen

You can adjust the resolution by going to:

Display and Monitor -> Screen icon with four arrows-> Pick host resolution

We tried shipping Whonix with a larger default resolution but unfortunately there is no foolproof way to configure settings on KDE.


Allocate more memory for workstation
#3
This will change when paravirtualized graphics (virgil3d) become part of KVM in Debian Stretch.

aha ok , so is it anytime soon or c u in the afterlife ?

(I ship ws with 2 cores already doesn't it appear when you first import the vm?)

yeah true , sorry i meant 3.


#4

Maybe you can install the KVM version that comes with that feature manually or from some third party repository or from backports? Not sure, HulaHoop would like to support that use case, though.


#5
Maybe you can install the KVM version that comes with that feature manually or from some third party repository or from backports? Not sure, HulaHoop would like to support that use case, though.

I would but unfortunately not all parts of it are developed yet for early testing.


#6

TNT BOM BOM,

I see very quick responsiveness in all the OSes I run under KVM. I use Fedora 22 and Gentoo Hardened as my KVM Hosts. I agree that the Workstation runs (slightly) slower than some of my other KVMs Guests, but the Workstation certainly performs from a speed/responsiveness perspective within acceptable limits.

Another test you may want to try to isolate the real cause:

Cleanly install Debian Jessie from an *iso as a KVM Guest. Fire up your Gateway In KVM, start and point your new Jessie at the Gateway, and compare its speed against the Workstation using identical memory and CPU allocations.

Feel free to report your experimental results, as they may help others. It would also help to provide your KVM Host system specs.


#7
I agree that the Workstation runs (slightly) slower than some of my other KVMs Guests, but the Workstation certainly performs from a speed/responsiveness perspective within acceptable limits.

if its within the acceptable limits i wouldnt report that, but its beyond the limits actually i cant do something well even when scrolling the page up and down its very laggy.

Cleanly install Debian Jessie from an *iso as a KVM Guest. Fire up your Gateway In KVM, start and point your new Jessie at the Gateway, and compare its speed against the Workstation using identical memory and CPU allocations.

Feel free to report your experimental results, as they may help others. It would also help to provide your KVM Host system specs.

do u have any detailed instructions to follow how to connect jessie witha gateway inside the kvm? not really sure i can make that alone.


#8

Maybe give this a try in the KVM guests…

sudo vi /usr/share/X11/xorg.conf.d/50-qxl.conf

Section "Device"
  Identifier "qxl"
  Driver "qxl"
  Option "ENABLE_SURFACES" "False"
EndSection

And reboot

http://lists.freedesktop.org/archives/spice-devel/2012-November/011479.html


#9

@who me? That won’t help. Yesterday I checked and found a qxl conf file with these settings that comes by default. I can’t find the link now but its already shipped with the qxl package.


#10

Sure it’s not being pushed by something else? Or maybe host video card related? I’ve been using Jessie on host and guest for a long time now and I’ve always needed to manually add in those settings. They are not needed using Jessie host with Wheezy guests.


#11

so do u think its going to be fixed with whonix 11 release or 12 ? or there is no clean view on when this issue going to be solved ?


#12

Not a Whonix problem, but it you should see KVM graphics improvements by Debian Stretch.


#13

I have been noticing this slowness problem myself too, but it is especially the worst within Tor Browser. When viewing a web page with lots of vertical content, trying to grab the scrollbar on the right and drag the page up or down, takes on average 5-10 seconds before the start of the drag is even acknowledged onscreen, then another few seconds before the screen changes position suddenly to reflect the scroll.

Scrolling is not as tertible in lighter programs like gedit, but with lots of graphics as in a browser, the scrolling is very evidently delayed.


#14

I tested Whonix 11 under Virtualbox just to see the difference, and everything is lightning fast in that version. Scrolling and screen refresh happens instantaneously just like in host system running non-emulated, as one would hope.

Only under KVM is there lag and delay. Even in the initial console/terminal bootup process, under Virtualbox the text displayed scrolls up smoothly so that you can see every line. Under KVM, it is stuttered and only refreshes intermittently, so it’s not even related to graphics intensity per se.

One thing to point out is that I am currently testing under Linux Mint, and when I first went to run the Gateway under Virtual Manager, it gave me a message that the package “Spice” could not be found, and thus no graphical display was available. I had to install that package manually in Mint before it would work. Could that have anything to do with it, and could additional configuration be needed? I didn’t have to install Spice under Ubuntu, so when I have a chance I will retest under that host and see if I encounter the same sluggishness.


#15

[quote=“who me?, post:8, topic:1247”]Maybe give this a try in the KVM guests…

sudo vi /usr/share/X11/xorg.conf.d/50-qxl.conf

Section "Device"
  Identifier "qxl"
  Driver "qxl"
  Option "ENABLE_SURFACES" "False"
EndSection

And reboot

http://lists.freedesktop.org/archives/spice-devel/2012-November/011479.html[/quote]

@who me? i have to give u big thanks! it just works! my tor browser become smooooooooooth now! i don’t know why the surfaces feature threw so many errors in Xorg.0.log

@Patrick , @HulaHoop i’d like to advise u to make the surfaces feature disable by default in whonix. at least, pls mention it in wiki. it took me sooooo much time to try many workarounds and finally i found this one.
PS: my host is latest linux mint.


#16

Thanks for the feedback whonix_user.

@Otto Kratik can you try whonix_user’s workaround and report if anything improved?

If you confirm the workaround I’ll tell Patrick and it will be included in Whonix ASAP.


#17

[quote=“HulaHoop, post:16, topic:1247”]@Otto Kratik can you try whonix_user’s workaround and report if anything improved?
If you confirm the workaround I’ll tell Patrick and it will be included in Whonix ASAP.[/quote]

Yes, I can now indeed confirm that the proposed solution does appear to work for me as well!

I initially thought that it hadn’t, since after creating that conf file in each guest and then restarting, the terminal boot-up text sequence still looked sluggish and stuttery as previous, as opposed to Virtualbox where it is instantaneously fast-refreshing.

However once the Workstation loaded fully and I launched Tor Browser, the difference was immediately drastically noticeable and everything now works smoothly just like in the host system (Linux Mint). An extreme improvement over all, and the entire Whonix environment under KVM now feels just as it does under Virtualbox: fluid and sleek and quick.

I’d definitely recommend that Patrick incorporate this change into Whonix for dramatically better KVM performance.

Thanks!


#18

Please send a pull request.


#19

I’m presuming that instruction is intended for HulaHoop, since well… I don’t have any idea how to do it, and probably lack the access as well.


#20

Anyone. Pull requests can be proposed by anyone.