[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Konsole hangs when installing software

Hello,

The terminal (Konsole) hangs when I want to install additional software.

user@host:~$ kdesudo apt-get install xterm
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
  xbitmaps
Suggested packages:
  xfonts-cyrillic
The following NEW packages will be installed:
  xbitmaps xterm
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 642 kB of archives.
After this operation, 1,879 kB of additional disk space will be used.

The question " Do you want to continue? [Y/n]" is not showing and the terminal seems to hang.

I tried to force the installation with “apt-get -y” but this option is not recognized.

user@host:~$ kdesudo apt-get -y install xterm
kdesudo: Unknown option 'y'.
kdesudo: Use --help to get a list of available command line options.
user@host:~$ 

Actually I wanted to replace the KDE-desktop with LXDE because KDE consumes to much system-resources. Tor-browser hangs when I have more then three tabs open and the system is responding slow on this computer. Also the always ‘jumping icons’ beneath the mouse-pointer I do not like in KDE.
So I tried to install LXDE and there the problem with the hanging terminal started.
First I thought that de Konsole causes the hang, so I tried to install the lighter xterm as terminal.

How can I resolve the problem with the hanging terminal (Konsole) when installing software?

Any help is much appreciated.
If you need more information, please let me know.

Thanx in advance,
xud

Good day,

How much RAM did you assign to the machine?

Have a nice day,

Ego

Thanks for your quick reply.

I did not know one can assign/adjust RAM to the guest-OS! How can I do this?

There is quite a difference between RAM in host and guest:

In host (Debian):

user@host-2:~$ cat /proc/meminfo
MemTotal:        3929848 kB
MemFree:         1655728 kB
MemAvailable:    1857916 kB
Buffers:           26912 kB
Cached:           359348 kB
SwapCached:            0 kB
Active:           466868 kB
Inactive:         182648 kB

.
(....)

In guest (Whonix)

user@host:~$ cat /proc/meminfo
MemTotal:         771756 kB
MemFree:          229976 kB
MemAvailable:     440632 kB
Buffers:           28760 kB
Cached:           284568 kB
SwapCached:            0 kB
Active:           307324 kB
Inactive:         193900 kB

.
(...)

Good day,

Regard this: https://www.whonix.org/wiki/Desktop#RAM_Adjusted_Desktop_Starter

Have a nice day,

Ego

Duplicate of thread from 4 days ago: Apt-Get Stuck???

Just reimport your Whonix images (assuming you’ve read and tried man apt-get: ie --clean, -f, etc)

Don’t use kdesudo for cli tools. Use kdesudo for graphical tools only. Otherwise just sudo. Follow the instructions for updating.

https://www.whonix.org/wiki/Update


Thanks everyone! Problem is solved.

During gateway-boot I used the option to CNTRL + D and started the gateway without the GUI. And I used sudo instead of kdesudo for installing software.
Problem solved!
Thanks for your help, and thanks Patrick for the link about other DE 's.

Keep up the good work!
:slight_smile:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]