[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Kgpg not using GnuPG2


#1

I seem to have set Kgpg to use GnuPG v2, but whenever I generate a new key pair, it seems to be GnuPG v1

What am I doing wrong?

It Kgpg settings I have set the path to /usr/bin/gpg2


#2

Hi LakeMonster

This can be sorted out as per https://whonix.org/wiki/Support#Free_Support_Principle

Setting Kgpg, to use GnuPG2 is not Whonix specific. You may want to try searching the internet for info/documentation on this topic or gpg, kgpg specific forums.

Also: Kgpg can be a bit buggy (many users report problems with kgpg). Try using just gpg.


#3

@Patrick Do you think its best to configure KGpg to use v2 if I figure our how?


#4

HulaHoop:

@Patrick Do you think its best to configure KGpg to use v2 if I figure our how?

Yes.


#5

/home/user/.kde/share/config/kgpgrc

[GPG Settings]
gpg_bin_path[$e]=gpg2

@Patrick where do I add this on git?


#6

#7

#8

Merged.

[GPG Settings] was duplicated but I fixed that. Untested.


#9

If I am on TESTING repos, I just need to update my template to apply this change, correct?


#10

My bad. Thanks for sorting it out.


#11

Whonix 14 only. All repositories. BUT!

This only takes effect for newly created user accounts / newly created configs. Not for existing user accounts / configs. I.e. only works if there is no kgpg config in user’s home folder yet.

Option 1:

Stop kgpg.

Edit.

~/.kde/share/config/kgpgrc

Emulate these changes. Save.

Restart kgpg.

Option 2:

Use kgpg graphical user interface to make these changes.