Kernel Panic error in Whonix Gateway (VBox)


I tried to search for other similar topics but haven’t found any help from them.

I run Whonix Gateway with 192 mb of RAM in a linux OS 64bit. Of course I keep everything up to date.

The VM goes in kernel panic while executing “sudo apt-get upgrade”.

It also appears randomly, during normal use of whonix gateway, some kind of warning message:

433.348893] mptscsih: ioc0: attempting target reset! (sc=ffff81021b950940) 433.348896] sd 0:0:0:0: [sda] CDB: ATA command pass through(16): 85 08 0e 00 d5 00 01 00 09 00 4f 00 c2 00 b0 00 433.605026] mptscsih: ioc0: target reset: SUCCESS (sc=ffff81021b950940

Is not the exact log of whonix gateway. I copied pasted that just as an example.

I can’t understand if this happens for my lack of resources or because I did something wrong.

I already tried to:

  • Using / Not using pae: still happens
  • Re-download and re-install Whonix Gateway many times: still happens

It looks like it happens only when whonix is in terminal mode. Never happened with GUI anyway I can’t keep it that way cause I have a total of 4gb of ram.
I can’t use other software different from virtualbox cause I don’t have a processor that support that damn hardware virtualization thing like intel-VT.

When whonix goes in kernel panic of course the VM is frozen and I can’t do anything, I just force the poweroff via Virtualbox.

I don’t understand why it doesn’t work like it used to. How can I fix this? Is it because my laptop is too old?
There must be a way to make it work like before if until whonix 9 everything worked perfectly.


Try adding more RAM during upgrades.

Related, just now added to documentation:


[quote=“Patrick, post:2, topic:1487”]Try adding more RAM during upgrades.

Related, just now added to documentation:

Thanks for your reply now looks like it’s working. I had whonix Gateway on an external drive, I moved it in the internal drive and now I don’t get that error anymore.

However I get another error, I don’t know if it’s related. And this was happening before, always after the latest updates of whonix gateway. Basically it happens that often (definitely too often! Pretty much every 10 minutes) that clearnet websites are impossible to reach: “Server Not Found” error in firefox. It was happening in the past but rarely and usually using “sudo service tor restart” fixed that issue back then. Now even if I use that command several times the problem stays for like 10 to 20 minutes. Hidden service are all working up gr8, other clearnet websites sometimes work sometimes not, but the original issue stays for 10 to 20 minutes.
After this time when I press F5 again finally it starts loading the website again.

Now I wrote this just to ask: do you think it’s a whonix problem or my workstation problem (currently a windows VM machine?).

Like I said I use since forever Whonix Gateway + windows without issues so these are new problems with latest updates… what can I do? Of course it happens even after downloading/re-install whonix gateway