[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Keep history and data on Tor Browser in Qubes-Whonix

I want to use only Whonix Qube on Qubes OS. But i use Qubes as daily driver so i want to keep my data, history, logins and etc on a Personal Whonix Qube. How can i do this? I already tried to change tor browser settings but after a update or shutdown the VM, my history keep saved but my logins/data don’t.

  1. use an App Qube (not a disposable)

  2. The same way this should/should not can/cannot be done as on the Debian platform, as per https://www.whonix.org/wiki/Free_Support_Principle.

In this regard, Qubes-Whonix isn’t any different from a Qubes Debian based App Qube. Therefore the same way this should/should not can/cannot be done as in a Qubes Debian based App Qube as per https://www.whonix.org/wiki/Free_Support_Principle.

This is unspecific to (Qubes-)Whonix.

The Whonix Qube with AppVM or Standalone keep the data and history, yes. But im talking specifically about tor browser anon dist. After a update, all logins/data stored on Tor Browser anon dist gets deleted even with StandaloneVM. With Debian Qube all history and data keeps saved since it uses Firefox ESR but i want to use Tor Browser for stronger security and anonymity, since i have all Qubes traffic through tor and don’t want to have clearnet traffic on it. Also i already tried to use Firefox ESR on Whonix Qube but some sites don’t load. I think this is caused by Whonix Firewall.

Whonix by design doesn’t make that type of change to Tor Browser.

The specificity to Whonix is by design as minimal as possible and such changes aren’t attempted.

What the downloader is, does, isn’t and doesn’t do, documented just now:
Tor Browser Downloader (by Whonix developers) Differences

Also:

This is specific to Tor Browser and unspecific to Whonix. The same should happen in Debian (in Qubes or standalone).

Otherwise please try to reproduce this on other platforms:
Tor Browser Functionality on Different Platforms

This is related to websites blocking Tor. (Not Whonix.)

See:
Bypass Tor Censorship

Can Whonix ™ be the cause of the inability to access specific destination websites? No. If connectivity is generally functional (some websites can be reached), never in the history of Whonix ™, any website were reachable in Tor Browser outside of Whonix ™ (such as Tor Browser on Debian) while unreachable in Tor Browser inside of Whonix ™.

Firefox shouldn’t be used in Whonix. Reasons:

It is an invalid comparison to compare Firefox data persistence versus Tor Browser inside Whonix data persistence. For a valid comparison, same link:
Tor Browser Functionality on Different Platforms

Tor Browser default (as defined by The Tor Project (TPO), not Whonix) is to not persist data. Whonix doesn’t develop Tor Browser. Persisting data in Tor Browser isn’t recommended by either TPO or Whonix.

More on such relationships here:

If you want to change the way Tor Browser operates then this will only be possible as per:
https://www.whonix.org/wiki/Free_Support_Principle

Yes, but i want to use Tor Browser without deleting my logins/data because i already have 1 separate and Disposable VM to anonymous activities. So i want to use another qube, personal, the Qube that i want to store my logins/data. I want to use Whonix since it is the best OS for anonymity and one of the best for security. I already tried to use KickSecure but since Kicksecure isn’t designed for anonymity, this is not my choice. Also i’m having some problems with onionized repositories on Kicksecure.

No. This happened with any site that i tried to access with Firefox ESR. Even the Firefox site i couldn’t access. Only Duckduckgo, Youtube and Google was working.

I’m aware of the security risks. But this VM i want to use for daily activities so i want to store all my data.

I will search for that. I asked for help here because on Tor Browser (Not Whonix) i just disabled the “Always use private browsing mode” and everything worked fine. None of my datas or logins get deleted. But on Whonix all data/logins (E.g Whonix forum account, Youtube, etc) gets deleted. Only History keeping.

Anyway thanks for your replies! I thought that whonix does some modifications to Tor Browser. Now i know it doesn’t.

What do you mean by “couldn’t access”? A captcha? A HTML page generated that this browser was denied? Well, in both cases the connection to the website actually succeeded. Just the server decided not to serve the Tor users. If it’s a browser generated (built-in) page that’s different but still most likely the same reason. In that case, the server would decide to not send any reply to the user’s browser but less common and less likely.

Cloudflare has detection of Tor Browser (over Tor) and actually treats Tor Browser better than Firefox over Tor.

Quote https://blog.cloudflare.com/cloudflare-onion-service/

Today’s edition of the Crypto Week introduces an “opportunistic” solution to this problem, so that under suitable conditions, anyone using Tor Browser 8.0 will benefit from improved security and performance when visiting Cloudflare websites without having to face a CAPTCHA.

Therefore unfortunately comparing Tor Browser (over Tor) inside Whonix with Firefox over Tor without Whonix isn’t a valid comparison anymore.

Try some sites of Tor-friendly / privacy friendly websites. They’re probably all functional.

It would be difficult for me to add an anti-feature “allow access to nitter.net but prohibit access to twitter.com”. I’d have to think about it, I don’t even want to think about it. Just saying such anti-features don’t happen by accident. Neither I can imagine any bugs that could cause such specific breakage.

Unspecific to Kicksecure / Whonix most likely. Mentioned here:
Non-functional Onion Services

No. The page that appears is the same when you don’t have internet connection. If the site blocks tor, you receive an warning of access denied from cloudflare or something. This was not the case. I can’t send screenshot since i have deleted this VM and i already solved my problem of Keep history/data on Tor Browser. But yes, this happened. And i tried many, many sites, even those which are privacy/security focused. If you want i can create another VM just to test it.

Talking about other thing, is there a way to disable/uninstall sdwdate on Whonix? I want to have a vault qube Whonix based, since Whonix is much more secure than Debian/Fedora. With sdwdate, the Whonix icon in taskbar its “sdwdate failed” even without sys-whonix attached to it.

1 topic = 1 forum topic please.

If this issue persists, please create a separate forum thread for it with a good description with all of these details so anyone can follow even without no prior knowledge of this forum thread.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]