[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Installing Qubes EFI Problem

Hello guys,

Im trying to transition from windows to QUBES so this will be my first OS other than windows and my first experience with linux, I know its tough to start with qubes but I think I can handle it especially with your help :slight_smile:

I am currently using windows 10, and after learning that dual booting windows can cause an evil maid vulnerability so I decided to completely erase windows and only use qubes and run windows in a vm if I need to use software like Photoshop…

So I downloaded qubes checked the signatures and burned it to a dual layer DVD, backed up my data, logged in to the bios and enabled virtualization ( Didnt find VT-d, just enable virtualization option so hopefully it includes VT-d), , disabled secured boot and in bios, and in UEFI boot manager made the cdrom my first boot device, then inserted the DVD, restarted, grub loaded with three choices

  1. verify and install 2. Install 3. Recover

if I click on any of the the first or second choices to install I get an error:

/EndEntire

Filepath: ACPI(a0341d0,0)/PCI(2,1f)/UnknownMessaging(12)/File(/EFI/Boot)/file(Xen.efi)/EndEntire

Now what could be going wrong?

Form a little bit of google searching it seems to be an EFI boot problem But cant pinpoint which problem
exactly.

Maybe my efi partiotion is not the first partition? Maybe I need to edit some boot stuff? But I don’t know whereor how from windows…Please help me with this Boot problem.

also

Should I try enabling legacy mode? Is legacy as good as EFI? it ok if I stay on legacy mode if it works or it can cause issues later on? Is it as secure?

Will/Can Qubes Erace Windows while installing?

I still am not sure if my laptops hardware is fully compatible with qubes, should I hold erasing windows until Qubes
install and all works?

Thanks in advance

Good day,

That’d be what I’d recommend to you. Helped on my Lenovo-Notebook when I first tried installing a Linux of any sorts. What also helps on certain distributions, especially those build on Fedora (like Qubes) was setting network boot as first in the boot sequence, for some reason, even though it isn’t used…

In what context? That’s a very complex question to answer, as it has a lot of strings attached to it.

Should cause no problems, as far as I’m concerned.

If you don’t use SecureBoot anyways, it isn’t unsafer.

If you need the PC for something, I’d recommend it obviously.

Have a nice day,

Ego

Thanks Ego For your reply,

i tried legacy mode but it didnt work, same error. any other ideas?

if i fdisk the hdd or totally remove all data along with the EFI partition and insert Qubes DVD, would that help or make it worse? should i try to make a new EFI partition?

Good day,

Like said, sometimes setting network boot as first and after that the CD/DVD-drive in the boot sequence help for some reason…

Should. as far as I’m concerned not have any effect, as you at this point in time only use the DVD to boot, so any HDD attached shouldn’t create any issues. Of course, if you are able to try it without the HDD attached/filled with data, I’d recommend doing it anyway, just to make sure, as there sometimes happen to be issues which don’t follow any rime or reason.

Have a nice day,

Ego

Secure boot is only a a marketing stunt. The only thing it “secures” is making it harder installing non-Windows operating systems from being installed on your computer.

https://www.fsf.org/campaigns/secure-boot-vs-restricted-boot


This forum is for Qubes-Whonix. It pre-supposes you got started with Qubes. EFI issues are exclusivly Qubes issues. Therefore please rather go through the Qubes support channels.


See also:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]