[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Installing KVM conflicting directions

I am a new user downloading for first time. I see directions in top of forum here and different directions in the wiki. It is confusing. The commands are not importing the XML files because it says the files do not exist. When I look at the files I have downloaded, they are slightly different.

Also, in my file manager it says xml files last updated in 2015. Is that true?

Wiki KVM Directions

  1. virsh -c qemu:///system net-define Whonix-External.xml
  2. virsh -c qemu:///system net-define Whonix-Internal.xml
  3. virsh -c qemu:///system net-autostart Whonix-External
  4. virsh -c qemu:///system net-start Whonix-External
  5. virsh -c qemu:///system net-autostart Whonix-Internal
  6. virsh -c qemu:///system net-start Whonix-Internal
  7. virsh -c qemu:///system define Whonix-Gateway*.xml
  8. virsh -c qemu:///system define Whonix-Workstation*.xml

Whonix KVM Forum Directions Pinned Post

  1. virsh -c qemu:///system net-define internal/external_network.xml
  2. virsh -c qemu:///system net-autostart internal/external
  3. virsh -c qemu:///system net-start internal/external

The files that are downloaded in 15.0.0.0.9

  1. Whonix_external_network-15.0.0.0.9.xml
  2. Whonix-Gateway-XFCE-15.0.0.0.9.xml
  3. Whonix_internal_network-15.0.0.0.9.xml
  4. Whonix-Workstation-XFCE-15.0.0.0.9.xml
    ///////////////////////////
    So what is going on here? The directions do not match the files I have.

update: am i correct in assuming that the references to internal network and external network are “Whonix_external network-15.0.0.0.9.xml” and “Whonix_internal_network-15.0.0.0.9.xml”? I want to be certain before proceeding because the download page brought me to sourcefourge, i verified the pgp signature but still. cant be too careful these days

Well yes. You can also just type Whonix_external* where * isa wildcard

This should always be enough.

I haven’t tailored the instructions to be exact since I figured people will be able to understand and apply them easily with the needed modifcations. The situation should improve when the next point release comes.

1 Like

This is the first time whatthehell has posted — let’s welcome them to our community!

I see you are dissatisfied with the level of service. Please hold while I issue you a refund…

:smiley:

1 Like

Can I get some free upgrades too? :rofl:

I’ve gotten all the way through, and on the final network virsh command, “virsh -c qemu:///system net-start external” I get the following errors

error: Failed to start network whonixee
error: The name is not activatable

As you can see, I changed the network name to “whonixee”. No matter what I change the network name to in the xml file it says the same error. I even tried changing the virtbridge name to no avail

by the way, i am not an unhappy customer. whatthehell reflected my mood at the time of posting, after spending a few hours trying to figure this all out. now im another 12+ hours in, been trying all day. i will say tho it is kind of crazy to have my account put on hold and posts approved just because of a username. so i guess the name whatthehell suffices :slight_smile:

What networks do you already have defined under there? Check under edit -> connection details -> virtual networks

My guess is that you are trying to start two virtual networks with the same virtualbridge number.

Also what host OS are you on? For best results use Debian it’s easy for me to help this way. On otherdistros I can try and find a solution, but if one doesn’t readily show up you are on your own to tell the upstream devs.

What’s crazy is the amount of spam we have to deal with.