[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

initramfs-tools - Begin: Running /scripts/local-block ... done. - takes a long time during boot - RESUME=none

Icons are missing on the desktop. They are in the /home/user/Desktop folder, however. This got lost somewhere between 13 and 14. (edit by Patrick to concentrate on initramfs in this split thread only.)

When the initramfs gets updated due to whatever reason (like new kernel, grub-live, manually running update-initramfs -u -k all) you get an additional boot delay of ~30 sec where it runs some scripts/local-block. This is a known issue: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=860533

RESUME=none has to be added either to /etc/initramfs-tools/initramfs.conf or to some file in /etc/initramfs-tools/conf.d/ and then upgrade the initramfs.
Not sure if this will have any adverse effects though.

Important for grub-live testers: ip=frommedia has to be added to the kernel command line either during boot or in grub.cfg. Otherwise the network interfaces won’t be configured.

Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.
Begin: Running /scripts/local-block ... done.

1 Like

Said to be fixed in 0.129 and stretch has 0.130? Are you sure this is still relevant?

( https://packages.debian.org/stretch/initramfs-tools )

.d always preferred.

Yes.

From their discussion… Is there a resume device UUID specified in /etc/initramfs-tools/conf.d/resume that does not exist? (Or any other initramfs config file?) If so, that could be a leftover from chroot build system, which I’d clean/up prevent somehow instead.

sudo bash -x /var/lib/dpkg/info/whonix-ws-desktop-shortcuts.postinst configure is probably fine. ~/Desktop is probably fine. Requires enabling kde folderview desktop setting.

Problem is, no one knows how to enable kde-folderview in Stretch’s KDE version. So no more desktop shortcuts by default.

https://phabricator.whonix.org/T633

Yes I was also wondering why but it still happens. According to man initramfs.conf the default behavior is to now resume from the largest swap partition which in case of Whonix is the encrypted one generated each time on boot.

1 Like

swap-file-creator was removed from anon-meta-packages with today’s package upgrades for Whonix 14.

sudo apt-get update
sudo apt-get dist-upgrade

Important, one has to apt-get autoremove so swap-file-creator gets removed.

sudo apt-get autoremove

Please check if really removed.

dpkg -l | grep swap-file-creator

After removal of swap-file-creator, I’ve run

sudo update-initramfs -u

then after and didn’t see the Begin: Running /scripts/local-block ... done. that slowed down the boot.

Does this fix this issue for everyone else as well?

1 Like

Works here.

1 Like

swap-file-creator is back.

And this issue is back too.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]