[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Infinite loop after(or while) dist-upgrade

I’ve tried to run apt-get dist-upgrade on Whonix-Gateway(Whonix-Workstation might also be affected as it froze once when I tried to dist-upgrade it but it may also be caused by the many windows I had open). The last time I called apt was for an upgrade(not dist-upgrade) and it succeeded.

It starts not to accept any keystrokes when installing the kernel if I remember correctly(it took some time when it reached that step so I went AFK). The output now looks like this:


As we can see, the information at the end is the same as the information at the beginning(this looks like it’s stuck in an infinite loop).

The message actually doesn’t repeat itself forever. Now it looks like this:


I think I should wait.
According to virt-manager, the guest’s CPU is almost unused(at least when I’m looking).

EDIT: I noticed characters have been cut while taking the screeshot. It’s only one character each line that’s been cut, so it should still be readable.

EDIT2: I’m using the stable repository.

Hi kranatafa

What hypervisor are you using? How much RAM do you have allocated to Whonix-Gateway/Workstation VMs?. If you had similar problems with Whonix-Workstation due to to many tabs open (not enough RAM) it may be a similar issue with both VMs

First try shutting down all unnecessary processes on your host and try updating Whonix-Gateway. (without Whonix-Workstation running)

If that does not work try increasing RAM in Whonix-Gateway using rads.

Then decreasing to RAM to minimum, 512 for a desktop environment, 256 for terminal-only

3 Likes

–> KVM

//cc @HulaHoop

The host has about 4 GB RAM, Whonix-Workstation has 1747 MB. I thought I had given Whonix-Gateway max RAM already(having a cli). It was at 120 MB something or 160 MB something. I can’t remember anymore. Whonix-Gateway seems to be working now after RAM was raised. According to the link you sent, 256 MB is the minimum. This may explain why the Gateway had problems.

I will try to see if I am able to allocate a good amount of RAM for the Workstation later(I currently do not have enough time to do it immediately.).

My best advice to you is to rollback to a clean snapshot and try again. Make it a habit to take a snapshot before you even do first boot. Sometimes mysterious bugs that crop up can be made to disappear that way.

2 Likes
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]