[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

I2P is not working in whonix-workstation

I followed all instructions on this page ‘https://www.whonix.org/wiki/I2P’ but I could not able to get it running. I done all the steps and then waited for few hrs and checked the status as well.
‘sudo systemctl status i2p’ timer showing network is activated 30 min ago. I still cant access i2p websites through tor browser. Time out error and server not found error.
I checked the iceweasel and I can see foxyproxy extension but not activated, in tor browser I cant see anything as such.

Is there anything else I suppose to do?

Works for me. Installed 9.27 and within 5 mins of startup it had connected.

1 Like

working for you but not for me :disappointed_relieved:
what is 9.27?
and do I need to change proxy settings in Tor browser ?

Tray:

what is 9.27?

i2p package version?

and do I need to change proxy settings in Tor browser ?

Changes to Tor Browser are documented on https://www.whonix.org/wiki/I2P
under 3. Install FoxyProxy:. That’s it.

You can check ‘/var/log/i2p/wrapper.log’ to see if the I2P Router did start and succesfully build a tunnel.
But first you should read the Wikipage carefully and do the steps described there.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]