[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

I BEG FOR HELP!!! Setting Up Tor Obfuscated Bridges Error!!!

I beg for help, I’ve been getting A LOT of headaches trying to set up the obfuscated bridges in my whonix gateway.

I’ve followed the tutorial at http://kkkkkkkkkk63ava6.onion/wiki/Bridges , and after many many attempts still failure:

when “sudo service tor@default restart” after the proper modification of the /etc/tor/torrc file with all the bridges obtained in the tor website etc… I get an errors (which I can’t paste here because I can’t access the web with the whonix gateway) saying it failed at “anonymizing overlay network for TCP” and thus the status of the tor service is “failed”.

DOING a “sudo -u debian-tor tor --verify-config” for debugging, I see that the problem is in the misconfiguration of the torrc file, in fact the output of this command is basically “Read configuration file /etc/tor/torrc” and then “Unable to decode Bridge key digest” and then “Failed to parse/validate config: Bridge line did not parse. See logs for details”.

In the guide at http://kkkkkkkkkk63ava6.onion/wiki/Bridges at the beginning of the “Step 2” it’s also written highlighted “Do not copy and paste this list of bridge entries to the torrc file”, what does that mean? I also manually typed all the bridge characters one by one to fix it but obviously didn’t work…

BY THE WAY TO COPY THE obfs4 bridges from the tor site I had to manually write then down and then write them again in a txt file in the whonix gateway, since in the gateway I couldn’t bring any file, nither use a browser, and the scurl to download the page containing the bridges doesn’t work ither for the purpose…

At first I though I had misstyped one of the bridges characters, but then I checked again thoroughly and It was all correct! so I don’t understand why it is “Unable to decode Bridge key digest.”…

WHAT SHOULD I DO??
I BEG FOR HELP I NEED TO USE THE BRIDGES!!!

ps:I’m using the obfs4 type of bridges, and I’m sure the syntaxt is correct in the torrc file.
ps2: I also tried to set up the gui connection-bridge-wizard at https://www.whonix.org/blog/connection-bridge-wizard using https://github.com/Whonix/anon-connection-wizard but i’m too noob for that ( tough I tried that too!!!)

HELP ME PLEASE!!

1 Like

Hi @helpplease ! Don’t worry! The following tips may answer your questions and help you use Tor Bridge successfully.

The following is a process I just tested, and it works well for me:

  1. Obtain obfs4 bridge.
  2. Open the /etc/tor/torrc file and add the following line:

DisableNetwork 0
UseBridges 1
ClientTransportPlugin obfs4 exec /usr/bin/obfs4proxy managed
Bridge obfs4 194.132.209.164:47230 118B18F125AB3D62DEBC5D55CAB851714F4F05EA cert=aTYkv0iTDPS70NrXdU7Z4SuVgc7P64z4nXW/+oSnjFZQmS7Nf2Z3s5oSv1S7vsdd1Q3aCA iat-mode=0
Bridge obfs4 104.197.176.227:9443 F24547960C354961D86B488DA4D45707E1CADD01 cert=SBa+Ju2qgn9JCL9OPeDTVL2zepNAjOdIlbvUjyhgP+HzXh/lSQ/b3Xh4hSuJijZfqk5Raw iat-mode=0
Bridge obfs4 51.254.127.147:52430 2D859C1546A463C673049ABB5187A8A5F0807F1E cert=+kmaMz83Sec/sA7etIEWe9r60NcTQN3hsewt7VPAXjoJaxZikj90UsPRaxngzJct6RgFDQ iat-mode=0

Please notice that it the bridge information line consists of two part, the first part is the string Bridge which has to be typed manually by you self, the second part is the bridge information you obtained from the website in step 1.

I am not sure whether you are using Qubes/VBox/KVM, but you can just search keyword like “enable clipboard between two VM in (Qubes/VBox/KVM)” to solve your problem.

3 Likes

It is probably not your fault. The current anon-connection-wizard in Whonix stable is unfinished and broken. We have been working on it and I promise you will be able to use it in the near future, which will make the whole configuration process much easier :wink:

3 Likes

Okay, I just tried what you said and after running “sudo -u debian-tor tor --verify-config” to check if the /etc/tor/torrc file was giving any errors, I got:
"Configuration was valid"
THANK YOU x 1000000^1000000 times
Then I went on with the guide to reload the tor service etc… and everything worked like a charm !!!

REASON FOR THE ERROR:
After fixing everything thanks to Iry I wanted to know why I was getting that error, so I modified everything I had different in my last configuration of torrc file (the wrong configuration) except the tor obfs4 bridges. At the end, after all tests were done I came to the conclusion that the error was generated because of a misstype in the tor Bridges (I still don’t know where I had miss typed though!).

To avoid this little but nasty problem I suggest everybody to activate as iry suggested me to do the shared clipboard between the OSes (if you put bidirectional in the shared clipboard settings you’re fine), and with that copy the tor bridges from the OS where you got them to the whonix gateway (where there isn’t a browser thus unless you really know how to do stuff, you wont be able to obtain the bridges) in the torrc file with of course the proper syntax.


PS: The guide specifies to only use “bridges” and not “Bridges” if you want it to work, but I tested both ways and they both work. So perhaps you guys wanna modify that part of the guide and write that you can use both or whatever you want of course.

THANK YOU AGAIN IRY !!!

1 Like

No problem, @helpplease !

I like that you described your problem in such a detail and also offered everyone a suggestion when your own problem was solved :sunny:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]