[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

!Huge browsers problems using windows xp workstation!

Hello there, I’m really getting crazy here. I got this problem from almost a month.

For a long list of reasons I use whonix workstation with whonix gateway, but sometimes I use also that same whonix gateway with a windows xp workstation.

Right now this is what I tried:

  • Download a new windows xp .iso and install it
  • Download new whonix gateway to use only with win xp
    Problem persists.

When it happens: every damn time I use the browser and (some) other software.

Problem: basically all hidden services websites works without a single issue… clearnet websites work for a minute or less, then they become unreachable. I got NO WAY of connecting to the said website.

In detail here’s what happens:

1.Let’s say I visit whonix.org.
2. I visit the website like always via firefox… however after 20 seconds the server becomes impossible to reach.
3. I try to click any link that has whonix.org in the url, result: Impossible to reach server.
4. No matter what I do, press F5 doesn’t work, it does refresh the website but it looks like the browser doesn’t even try to load the website.
5. I try to restart tor service on whonix gateway, the problem persists.
6. After 10 to 20 minutes. Out of the blue, the website whonix.org, works again… for max 20 seconds then back to point 2. Server impossible to reach.

I tried with many browsers, including IE (yes I got that desperate) and IE it’s the only one that tells me that I have an FTP problem, but probably IE is wrong, we know IE is always wrong.

I really dunno what’s happening here, why I have these problem with windows workstation and not with whonix workstation???

Oh btw, IMPORTANT NOTE: I always worked this way, more than 1 year, and windows workstation always worked without issues in browser and all… I guess I’m having this problem since my last update to whonix gateway 11… all my problems began with that version of whonix.

Anyone is going by this hell like me? It’s really a critical problem to me and extremely stressful. It’s literally impossible to me to navigate to clearnet websites.

I love whonix workstation but unfortunately sometimes I forced to use that bitch of windows.

My main OS is Linux Lubuntu if that matters.

PLEASE HELP :expressionless:

edit: almost forgot, I use VirtualBox cause I don’t have alternatives currently (I don’t have intel-vt…)

Good day,

could you post what you have in your torrc?

Have a nice day,

Ego

[quote=“Ego, post:2, topic:1541”]Good day,

could you post what you have in your torrc?

Have a nice day,

Ego[/quote]

Thank you for your reply, for torrc you mean the text file in etc/tor/ ?

The file named torrc has never been edited by me, all lines are commented with # except one:

DisableNetwork 0

Then besides that toorc in the same folder I have the other ones which I guess are standard for everyone who use whonix:

torsocks.conf
torrc.examples
torrc.anondist
torrc.anondist-orig

What can I do? :expressionless:

Good day,

ok, that actually is completely fine. Are the adapter settings configured as mentioned in this guide: https://www.whonix.org/wiki/Other_Operating_Systems#Windows-Whonix-Workstation ?

Have a nice day,

Ego

Of course they are, I just checked again :frowning:
Anyway I downloaded another win .iso, this time Windows 7 ultimate and it works… right now…
I have my main OS (linux) installed on an usb pendrive… do you think that might an issue?
What happens if I decide to add a google/opendns DNS in the alternative DSN address that usually is left empty?

Thank you for your time man

Good day,

leave the DNS in the workstation, as is, as you’re supposed to use the one provided by the gateway, since it’s torrified and can’t be leaked. Using a pen drive shouldn’t have any impact and since you’ve said that it currently works with Windows 7, I’m assuming something with your installation of XP is wrong. I’d recommend against using XP anyway, for security reasons, but if you really want to use it, I can only recommend reinstalling it completely.

Have a nice day,

Ego

Thanks man unfortunately I’m forced to use windows sometimes and win 8 of course is not an option for a lack of resources… anyway thanks with a clean windows 7 I fixed my issues.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]