[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

How To Update Whonix

Hi guys I’m sorry if this is a stupid question but I am new to whonix and have the gateway setup with Virtual box had no issues but cant work out how to update. Whonix check shows

Warning: whonix news result:
x outdated:installed whonix-gateway-packages-dependencies 1.9-1 is outdated!
You should update. You can automaticcally update using whonix’s internal updater. Please update using: sudo apt-get update && sudo apt-get dist-upgrades

Below that also says apt-ger reports that 62 packages can be updated.

So how do I do this internal update I thought it was a case of opening terminal and typing or copy and pasting sudo apt-get update && sudo apt-get dist-upgrades like it says but once I put that in it asks for password but doesn’t allow me to type in the space what should/can I do?

Thanks in advance

Password entry:
Just type. No stars *** will be shown, but it will still work.

Usual upgrade:

For the upgrade from Whonix 10 to Whonix 11 you need special instructions:

Thanks Patrick would it be easier to download the new version all together and configure with my VM again because I’m having difficulty understanding the upgrade process?

Yes.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]