[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

How to run Telegram Messenger on Whonix 15 XFCE??

I downloaded the tar file for Linux on the official website Telegram, unpacked it but I can’t start the client.

Failed to execute child process “/home/user/Downloads/Telegram/Telegram” (No such file or directory).

On Whonix 14 KDE I didn’t have that problem. I did the same action and the client started. What could be the problem??

Does not look like Whonix specific issue. Should be “same as on Debian buster”. https://www.whonix.org/wiki/Free_Support_Principle applies.

Thanks for the reply. I have two virtual machines WHONIX WORKSTATION. One I updated from version 14 KDE to 15 XFCE version using the terminal and the user manual. After the update I got two DE - KDE and XFCE. The Telegram runs on both.
But I decided to download the new 15 version WHONIX from WHONIX site and configure the new machine and in the new virtual machine the Telegram did not get to run. During startup the client always appears an error window.

Failed to execute child process “/home/user/Downloads/Telegram/Telegram” (No such file or directory).

There’s no need to mess with tar files. Telegram is in the Debian repos. Run

sudo apt-get install telegram-desktop
2 Likes

Likely because you needed to compile it or do some other things.

Hi @madaidan,

Do you know how to hide the phoone number using telegream-dektop on Whonix?

It seems that option is not proposed under Privacy and Security.

Thanks for your answer.

Ask Telegram.

Telegram enforces phone number validation. Not Whonix.


Related:

@Patrick I know but when I install it using the command line I get an old version of Telegram and I don’t think this is a Telegram issue.

It should just be listed there.

image

image

Are you using a recent Telegram version? Where did you install it from?

Dear @madaidan

Thank you for your reply.

I used :

sudo apt-get install telegram-desktop

So I assume I am using the latest version. 1.5.11 (Desktop Version)

Hiding my phone number is not an option on my dekstop version which is running on Whonix.

But it is possible to hide it on the Windows Dektop Version v 2.4.5. Surprising :face_with_raised_eyebrow:

EDIT : I don’t have the latest version installed for a reason I ignore. How can I upgrade it?

@madaidan,

Well, I have the stable version installed and I need the testing version. Correct?

If so, I don’t know how to change the value from ‘stable’ to ‘testing’.

Would you kindly help me?

Try it and see if it fixes the issue.

Use Debian backports.

1 Like

@madaidan Perfect !
I am now running version 2.2.
Thank you very much for your help :partying_face: :blush:

1 Like

madaidan via Whonix Forum:

Use Debian backports.

https://backports.debian.org/Instructions/

Alternative instructions in Whonix wiki for use of Debian backports:

https://www.whonix.org/wiki/Install_Software#Backports

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]