[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

How to install Kali Linux on Whonix?

How to install Kali Linux on Whonix?
I only need packages from Kali, no virtualization.

Should be same as on Debian. Unspecific to Whonix.

https://www.addictivetips.com/ubuntu-linux-tips/kali-linux-apps-in-debian/

user@host:~$ sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ED444FF07D8D0BF6
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
Executing: /tmp/apt-key-gpghome.hvfu94hvbr/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ED444FF07D8D0BF6
gpg: keyserver receive failed: Operation not permitted

Could you try as per https://www.whonix.org/wiki/Free_Support_Principle please?

1 Like

I already googled, but did not understand what exactly the line should be.

user@host:~$ sudo gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ED444FF07D8D0BF6
[sudo] password for user:
gpg: directory ‘/root/.gnupg’ created
gpg: keybox ‘/root/.gnupg/pubring.kbx’ created
gpg: keyserver receive failed: Operation not permitted

As if there is no connection. But the browser works.

I tried various fixes that I found online, but none worked.

Can anyone help please?

Maybe there is a way to abandon the key system?

Insecure. Unsupported.

Most likely not. This is unrelated to Whonix and maybe even Debian.

apt-key as the command by Debian says is deprecated. It’s up to upstream to fix it.

gpg doesn’t work either. I do not know what to do.

I think the Kali repositories should be added to Whonix by default.
Then Whonix will become a tool for security testing.

I just installed Kali packages on Debian. There are no problems at all.
So this is a Whonix problem.

but:

I was able to install Kali packages but it was just hell.

It’s possible that hpk:// does not work over Tor or that the Ubuntu key server is blocking connections coming from the Tor network.

Whonix’s most essential feature is that is routes all traffic over the Tor network and it does that. All the side effects of that cannot be fixed inside Whonix.

Still not working:

  1. W: GPG error: http://ftp.halifax.rwth-aachen.de/kali kali-rolling InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY ED444FF07D8D0BF6

There are probably redundant steps here:

gpgconf --kill dirmngr
dirmngr --debug-all --daemon --standard-resolver

Add to home/user/.gnupg/dirmngr.conf standard-resolver
home/user/.gnupg/dirmngr.conf copy to /root/.gnupg/

gpg --verbose --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys ED444FF07D8D0BF6
gpg --verbose --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 7D8D0BF6

wget https://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2020.2_all.deb
sudo apt install ./kali-archive-keyring_2020.2_all.deb

sudo apt update

If you search for

ED444FF07D8D0BF6

the internet is full with people having issues with that.

1

scurl-download https://archive.kali.org/archive-key.asc

2

sudo cp archive-key.asc /etc/apt/trusted.gpg.d/

3

echo "deb http://http.kali.org/kali kali-rolling main contrib non-free" | sudo tee /etc/apt/sources.list.d/kali.list

It’s not doing fingerprint verification. → Verifying Software Signatures - Kicksecure

Bad usability in this case isn’t that something Whonix is causing or can fix.

Upstream documentation still using /etc/apt/sources.list instead of /etc/apt/sources.list.d/kali.list. Upstream documentation isn’t great, I had to combine these two:

I don’t quite understand what you mean, but thanks.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]