How to correctly configure A linux Mint VM network to connect and use Whonix Gateway tor connection.


Hello All at Whonix Virtualbox Forum.

Im an absolute begginer with whonix and tunneling other virtual machines through my whonix gateway tor network connection. this is basically why i’m here. id massively appreciate it if someone with experience could explain to me clearly how I can tunnel my Linux Lint 18.2 virtual machine network connection to use and tunnel through my whonix gateway vm network connection…
I have followed the instructions found here:
but, unfortunatley I Cannot access the internet when trying to tunnel my network connection through Whonix Gateway VM.
I know this is possible, but for some reason I cannot get access to the internet im confident im not configuring my linux mint network interfaces including:

kdesudo kwrite /etc/network/interfaces


kdesudo kwrite /etc/resolv.conf

Can somebody with experience of doing the above please kindly explain to me how to correctly configure my linux mint network to connect using whonix gateway connection ?

Could someone kindly let me know what I should be writing into correctly configure these :

kdesudo kwrite /etc/network/interfaces
kdesudo kwrite /etc/resolv.conf

to be able to connect and tunnel my linux mint virtual machine network connection through whonix tor gateway network connection, please ?

Thank-you in advance for any help given.


I still need help with this please.


BUMP I still need help with this please



So you want your torify your Linux Mint VM’s traffic through the Gateway, correct? Try the following:

In VirtualBox, select Linux Mint VM -> settings -> Network -> Chose Virtual Network/Whonix

Save and start the VM. In the VM, edit the /etc/network/interfaces file with a text editor and admin rights, or just type:

sudo nano /etc/network/interfaces

and type the following:

auto lo
iface lo inet loopback

allow-hotplug enp0s3
iface enp0s3 inet static

then type
sudo nano /etc/resolv.conf

and replace everything with the following line:


Reboot the machine and test it.

This way, you have configured the VM to use the Whonix-Gateway as its gateway (at local address and it will assign the static local IP to your VM. Use another last number if you wish to run your VM alongside Whonix-Workstation which also uses (chose for instance

I don’t know the purpose of this for you, but please note that Whonix-Workstation provides much better security than a simple torified VM.


Hello onion_knight.

Thankyou for your reply.
I will give this a try and post back how i got on.

Thnaks again



You are welcome. A small correction: last three lines in /etc/network/interfaces should be indented like this:

allow-hotplug enp0s3
iface enp0s3 inet static