[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

How to configure fetchmail in Whonix workstation?

How do I configure fetchmail on Whonix KVM workstation to poll a remote onion server over IMAP? The default settings do not work, it times out with “socket error while fetching”. There are instructions on how to setup fetchmail over Tor on the web, but these are not for transparent setups like Whonix.

Thanks.

I don’t know fetchmail but if you want to use the plugin option described on the page you linked, all you have to do is replace 17.0.0.1 with your gateways IP address and use one of the preconfigured SocksPorts for stream isolation.

Thanks, it seems like it should work but I need to keep trying because:

fetchmail: running socat STDIO SOCKS4a:10.152.152.10:%h:%p,socksport=9153 (host mailserver.name service imap)
2017/06/18 18:52:50 socat[23043] E socks: connect request rejected or failed

Tor doesn’t support all types of DNS.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]