[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

How do I unconfigure a non-loopback address

Windows 10 home x64 latest 2004 build version. VirtualBox latest version.
Latest Whonix Gateway XFCE / open Tor Control Panel / Logs tab…
Jun 15 03:47… [notice] You configured a non-loopback address ‘10.152.152.10:9229’ for HTTP TunnelPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.

I didn’t make any such changes, how can I rectify this?

Where do I begin, is it a Windows 10 problem, BIOS, VirtualBox, Whonix… where can I make the change?

For me, Whonix has been unusable for a week since Windows did its update to the latest build. I’m not going to change back to the old version.

No one else here or on the internet seems to have this same problem.

I wonder if this is the reason why I get many Hash Sum Mismatches when doing “sudo apt-get update && sudo apt-get dist-upgrade” and it is also impossible to let TOR update itself as all files download fail. Every download size larger than 1mb seems to fail.

Thanks.

Documented just now:
apt-get Hash Sum mismatch

Otherwise please create a separate forum thread for that.

I don’t know if it’s related. Hash sum mismatch probably is unrelated unless some Windows vs VirtualBox bug causes VirtualBox virtual hard drive inconsistencies.

Thanks for the response and empathy regarding my lack of linux knowledge.

I solved my problem, it was the Windows 10 Core Isolation feature, it was turned on for some reason.

It is nice to have the Windows 10 OS lookout for potential shenanigans
but if the safety settings “brick” other applications like VirtualBox, I just say WTF.

I hope this will help any other Windows 10 people, if there are any still remaining.

+++++

Notice: Reboot the PC when ever it displays a reboot suggestion.

  1. BIOS// Verify BIOS that SMV was enabled.
    CPU CONFIG tab / select SMV MODE / set it to ENABLE.

  2. Boot PC Windows 10.

  3. Win10// searchbar “Windows Features On Off” // open it //
    uncheck [ ] Virtual Machine Platform
    uncheck [ ] Windows Hypervisor Platform
    !-- I hope this doesn’t mess something else up --!

  4. Win10// searchbar “cmd” prompt, with admin powers: bcdedit /set hypervisorlaunchtype off
    [if you want to later enable it… bcdedit /set hypervisorlaunchtype auto].

  5. Win10// searchbar “Core Isolation” // open it // Memory integrity = off.

After all the changes and verifications above, and PC rebooting, launch VirtualBox and
run Whonix Gateway first, I always change the time in the tray first. Next
bring up terminal, sudo apt-get update && sudo apt-get dist-upgrade
and it will install without ‘Hash Sum mismatch’ and will download files without failing.

Then run Whonix Workstation, I always change the time in the tray first.
Next bring up terminal, sudo apt-get update && sudo apt-get dist-upgrade
and it will install without ‘Hash Sum mismatch’ and will download files without failing.

Run TOR webrowser and it will download/update without failed download message.

regarding non-loopback

After I fixed it, this “you configured a non-loopback…” message still appears in the Tor Log in the gateway, apparently this wasn’t the problem of my failed updates, sum mismatch, and failed downloads in Whonix.

smiling

1 Like

Closing this one in favor of Hash Sum mismatch, downloads all fail... since Win10 2004 update to avoid duplication.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]