[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

How can I watch youtube in Whonix Workstation?

Can anybody from this community help me with Youtube video? None of the browsers provided support it. It just freezes - no streaming. How come such a trivial thing as Youtube is not supported? I tried all kinds of plugins for Firefox and Chromium that installed - nothing works.
Does this distro at all support Youtube? Can anybody suggest what to do?

Good day,

Just merged the threads, there is no sense in creating two threads for the same question.

Furthermore, Whonix Supports YouTube without issue. Under a similar configuration, I, as well as many others, can use it without issue.

Have a nice day,

Ego

1 Like

Than what is wrong with my setup? My host is on KDE as well (Kubuntu). What can possible be wrong? I searched "“debian+youtube+issue” and get nothing, as if Google does not know about it. As if I’m a sole person on this planet to have such an issue.

None of the browsers plays on-line video on Whonix-Workstation.
Can someone help?

what, there is nobody here who can help??? No video support in the browsers - not possible to use Youtube in none of the browsers and nobody gives a damn??? Why is called “support” then?

Good day,

I already told you, creating a new thread for this won’t get People to help you faster.

If you’d use the Forum search you’d know that other People can use Youtube on Whonix in a similar Setup just fine.

Here is an example: Tor Browser can't play MP4 files

YouTube is working using HTML5.

It works fine for a lot of other People, including myself, so there is no one who can help you since this isn’t a known issue.

Yes, nobody can help, since you give no Information. I already asked you in post #7 whether you’d verified the Images and reinstalled VBox.

You ignored that.

Also, if you really want to figure out whether the issue lies with Whonix, try this: Set up a Debian VM on your System. Try Youtube on there. If it doesn’t work, we know where the issue lies.

Have a nice day,

Ego

2 Likes

If I may suggest a test. Start a new VM and install another OS. Then see if you can view Youtube videos in it with a plain browser. Maybe that is a good place to start.

2 Likes

https://tails.boum.org/support/faq/index.en.html#index28h2

On Tor Browser, you should both turn NoScript off and set the Security Level to “Standard”.

YouTube videos will not play (for me at least) with the “Safer” and “Safest” settings.

Hi,

I don’t know if this issue was resolved for the users that reported problem, but I now in 2020 also experiance this issue.
I’m at time of writing runing
Virtualbox Version 6.1.16 r140961 (Qt5.6.2)
Whonix-XFCE-15.0.1.5.1
Image was verified with the hases provided

Machine settings for graphics
128mb graphics memory
VMSVGA
3D Graphics (tried both on and off)

I’ve set the tor browser with noscript disabled and security on standard

I’ve also installed
Firefox (youtube and other doesn’t work)
brave (youtube and other doesn’t work)
chromiom (youtube doesn’t even open up)

While using firefox with the dev tools I did see that the browser gets a ether 204 or 404 on the contnt retrival .js link…
What I also see is that the player shows that the video content is loaded. It seems so play the first 1 to 2 sec then behaves as if it’s trying to buffer, (and if left long enough) it’ll replay that first 2 sec then repeat.

So a stupid question came up in my head. is there any filtering done on content on the gateway server?? before getting to the workstaion

I also installed the latest debian 10 in a new virtualbox, youtube doeswork, jittery with 3d off and fearly nice with 3D on. Useing firefox

Have anyone come up with workable suggestions?

brandc via Whonix Forum:

So a stupid question came up in my head. is there any filtering done on content on the gateway server?? before getting to the workstaion

No.

brandc via Whonix Forum:

I also installed the latest debian 10 in a new virtualbox, youtube doeswork, jittery with 3d off and fearly nice with 3D on. Useing firefox

Then Whonix isn’t the root cause.

If it doesn’t work in VirtualBox with Firefox, it’s not a Whonix issue.
Could you try to resolve as per
https://www.whonix.org/wiki/Free_Support_Principle please?

I think you mis read my statement on Debian 10. Youtube and other video streaming serives work 100% in Debain 10, I just put 3D on in Virtualbox.

So if I understand correctly. If it works in Debian but not in Whonix, the problem is not with whonix… (head screatcher)

That is an ancient virtual graphics card. Doesn’t support 2D for sure and 3D is of no use for these kinds of graphics workloads. In fact this criteria is useless with new graphics virtualization architectures at least for KVM.

If you want to play high quality videos with no hassle just switch to KVM and you should have no problem out of the gate.

Sure?

It was introduced relatively recently in VirtualBox.

https://gitlab.com/whonix/Whonix/-/blob/master/build-steps.d/2600_create-vbox-vm#L116

   ## equivalent to:
   ## VirtualBox → click a VM → Settings → Display → Graphics Controller → VMSVGA → OK
   ##
   ## Quote https://www.virtualbox.org/manual/ch03.html
   ## > "VMSVGA: Use this graphics controller to emulate a VMware SVGA graphics device."
   ## > "This is the default graphics controller for Linux guests."
   ##
   ## - Has better desktop resolution in CLI (virtual terminal) mode.
   ## - functional VirtualBox VM Window → View → Virtual Screen 1 → resize to resolution
   ## - functional VirtualBox VM Window → View → Adjust Window Size
   ##
   ## Broken for some users?
   ## https://forums.whonix.org/t/black-screen-on-15-0-0-6-6-and-15-0-0-7-1/8554
   sudo $SUDO_OPTS VBoxManage modifyvm "$VMNAME" --graphicscontroller vmsvga

From the available choices by VirtualBox, seem the correct choice for Whonix VirtualBox by default.

My bad. I confused it with an obsolete QEMU emulated video card with a similar name.

YouTube works for me. There are no VirtualBox performance issues after enabling 3D Acceleration. This however is discouraged for security reasons in documentation. Was able to watch a video in HD as well as in 4K quality with Tor Browser inside VirtualBox.

Without enabling VirtualBox 3D Acceleration video viewing experience is degraded to to low graphic performance.

Added to documentation just now:

VirtualBox users note: Performance of videos might be slow. For a possible solution, see VirtualBox, Troubleshooting: Slow Video Playback.

Quote VirtualBox, Troubleshooting: Slow Video Playback.

Options:

What’s better or worse for security, enable VirtualBox hardware-accelerated graphics (3D Acceleration) or disabling CPU mitigations? Please consider resolving that question through Free Support Principle and let us know what you found out. Please use a dedicated forum thread for that.

Related:
VirtualBox 3D Acceleration

Try KVM, much more secure.

No issue with YT here I don’t have 3d acceleration on.

Interesting. Thanks for the report.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]