[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Higher resolution desktop

Good catch. Will be installed in Whonix 10 and above (anon-shared-desktop 0.5 and above) by default.
git commit: https://github.com/Whonix/anon-meta-packages/commit/df631011b35475ab7f73cc80c4dde747cab5f470

Could you please run these commands in KVM?

sudo apt-get install read-edid
sudo get-edid ; echo $?

And post the output of the latter?

Shouldn’t contain private information, because we went through https://www.whonix.org/wiki/Protocol-Leak-Protection_and_Fingerprinting-Protection at your initial Whonix KVM efforts. Just double check to make sure.

I would like to add this information here:

I need help here…

The related file is:

For redistribution we later may put this file into:

(Not sure if a separate package would be justified.)

This will be quite difficult debugging wise. Debugging as in creating a config file and really testing it.

Quote https://github.com/Whonix/whonix-gw-kde-desktop-conf:

This package only takes effect for newly created user accounts. Not for existing user accounts. This package is most useful to help Linux distribution maintainers setting divergent defaults.

So to test this…

  1. Create a config file you want to test in /usr/share/whonix-gw-kde-desktop-conf/share/config/krandrrc
  2. Create a new user account “user2” or so
  3. Login as user2
  4. See if it worked
  5. Logout as user 2
  6. If it didn’t work, delete user2
  7. make sure the /home/user2 folder has been wiped or at least wipe /home/user2/.kde/share/config/krandrrc
  8. go back to 1. if necessary

This is because user settings always overrule distribution defaults and because once logged in once that user file has been created, so distributions have no more chance to change user settings (unless huge hacks are invented or kde gets patched).

Does my explanation about how to debug this make sense?

When you want to experiment with editing ~/.kde/share/config/krandrrc you can’t do this while kde is running. Stop it first. “sudo service kdm stop”. Edit that file. Start it again. “sudo service kdm start” See if it worked.

Also this is specific to VBox vs KVM.

My current ~/.kde/share/config/krandrrc (slightly redacted):

[Screen_0]                                                                                                                                     
OutputsUnified=false                                                                                                                           
UnifiedRect=0,0,0,0                                                                                                                            
UnifiedRotation=1                                                                                                                              
                                                                                                                                               
[Screen_0_Output_VBOX0]                                                                                                                        
Active=true
Rect=0,0,1024,768
RefreshRate=60
Rotation=1

Most times it’s best to ship minimal kde config files and let kde itself fill out the rest. For example, I could test.

[Screen_0_Output_VBOX0]                                                                                                                        
Rect=0,0,800,600

And see if that works.

You’ll likely have to replace “Screen_0_Output_VBOX0” with whatever that is in KVM.

get-edid: get-edid version 2.0.0

    Performing real mode VBE call                                                                                                          
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0                                                                                                 

halt_sys: file ��y�*+, line -1216758308
Function unsupported
Call successful

    VBE version 300
    VBE string at 0xc4f55 "SeaBIOS VBE(C) 2011"

VBE/DDC service about to be called
Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0

halt_sys: file ��y�*+, line -1216720908
Function unsupported
Call successful

Reading next EDID block

VBE/DDC service about to be called
Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0

halt_sys: file ��y�*+, line -1216720908
Function unsupported
Call successful

The EDID data should not be trusted as the VBE call failed
Error: output block unchanged
1

Also this is specific to VBox vs KVM.

I have been trying to get krandrrc to work but I think the problem is I don’t know what the KVM naming scheme is. Searches don’t show anything useful.

I really want this to work but I’m at a loss as to what to do next.

[quote=“HulaHoop, post:25, topic:471”][quote]Also this is specific to VBox vs KVM.
[/quote]

I have been trying to get krandrrc to work but I think the problem is I don’t know what the KVM naming scheme is. Searches don’t show anything useful.

I really want this to work but I’m at a loss as to what to do next.[/quote]
You don’t have to know that by search. You can know this by “reverse engineering”. Just change your resolution a few times. Then that file should get created.

ok which file should I look at to see this?

The file at /usr/share/whonix-ws-kde-desktop-conf/share/config/krandrrc
does not override whatever is at ~/.kde/share/config/krandrrc

~/.kde/share/config/krandrrc

[code][Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_default]
Active=true
Rect=0,0,1024,768
RefreshRate=75
Rotation=1
[/code]

/usr/share/whonix-ws-kde-desktop-conf/share/config/krandrrc

[code][Screen_0]
OutputsUnified=false
UnifiedRect=0,0,0,0
UnifiedRotation=1

[Screen_0_Output_default]
Active=true
Rect=0,0,1366,768
RefreshRate=60
Rotation=1[/code]

Is it possible to just ship with a modified ~/.kde/share/config/krandrrc even though its not good practice?

[quote=“HulaHoop, post:29, topic:471”]The file at /usr/share/whonix-ws-kde-desktop-conf/share/config/krandrrc
does not override whatever is at ~/.kde/share/config/krandrrc[/quote]
I know. I tried to explain that here:
https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084

Is it possible to just ship with a modified ~/.kde/share/config/krandrrc even though its not good practice?
Yes. Would have to be hardcoded to /home/user/.kde/share/config/krandrrc. Why would that be required, what would that be good for?
Yes. Would have to be hardcoded to /home/user/.kde/share/config/krandrrc. Why would that be required, what would that be good for?

Its one option thats about shipping Whonix with a hi-res out of the box, or alternatively the documentation tells people how to adjust this from KDE settings.

Using /usr/share/whonix-gw-kde-desktop-conf/share/config/krandrrc would also ship with hi-res out of the box for new build versions as per https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084. Not for existing users that upgrade.

OK so we’re all set? Do you have the configuration you need for this? I’m alright with doing a full upgrade :slight_smile:

The question is, does that config work for you?

/usr/share/whonix-ws-kde-desktop-conf/share/config/krandrrc

[Screen_0_Output_default]
Rect=0,0,1366,768

Have you debugged it as per https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084? Start testing with 1024x768 with user and then see if user2 ends up with changed different resolution thanks to that new config.

The question is, does that config work for you?

No it didn’t work. The way I do it is to change it for my main default user account ‘user’ its easier than creating a new user account and testing it there. Are these instructions relevant to this?

It won’t work because of https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084.

Yes very much so as per https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084.

https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084

I don’t think I understand how things work.

Alternatively please have Whonix ship the qxl xserver package and I’ll manually set the resolution from the gui after upgrades.

[quote=“HulaHoop, post:37, topic:471”]https://www.whonix.org/forum/index.php/topic,493.msg4084.html#msg4084

I don’t think I understand how things work.[/quote]
This is unfortunate. I wouldn’t know how to explain better.

I’ve explained the issue on kde user mailing list in slightly different words:
http://lists.kde.org/?l=kde&m=141130406809446&w=2

Hopefully they have suggestions on how to ease debugging.

Will be the case in next release.

There is one important test that needs to be done before shipping such a config so or so…

Set a KVM VM to a higher resolution than 1024x768.

Let’s imagine a user who can set at maximum 1024x768 on its host (or is using this for other reasons such as accessibility)… Please simulate being that user. Shut down the KVM VM. Set your host to 1024x768. Now start the KVM VM.

What happens? Will the KVM VM (that maybe will attempt setting a higher resolution than the host has currently set) still be usable? Or will some weird bug hapen? Screen still readable? Or VM window must be scrolled? With what resolution the KVM VM will start?

What happens?

The guest resolution stays 1024x768 and fills the whole host screen becuase the host is the same lower resolution during the test.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]