[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Hidden service set up


#1

Hello,
I m a newbie & following whonix instructions on home page to set up hidden services & stuck at following step
A HiddenServiceDir configuration
HiddenServicePort configuration

As per the instructions i added these 2 files to /etc/tor/torrc

HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 10.152.152.11:80

After this
sudo service tor reload
sudo service tor status - comes as active
but unabe to generate Tor Hidden service url using the following command
_sudo cat /var/lib/tor/hidden_service/hostname results in No such file or directory
Please help, what to do


#2

(I don’t know anything about hidden services.)

  1. I created a new VM with no networking.
  2. Followed the instructions here:
    https://www.whonix.org/wiki/Hidden_Services#Whonix-Gateway
  3. sudo cat /var/lib/tor/hidden_service/hostname gives me an .onion address.

Most likely you made a typo.
(HiddenServiceDir /var/lib/tor/hiddenservice/_ <- is that an underscore at the end?)


#3

Hi entr0py,
Thank you for your reply, i appriciate it

  1. This is where i was following instructions from (same link as you recommended )
  2. No it’s not a underscore but due to Italicising the line

I think my probelm lies with this -

As per the instructions i added these 2 files to /etc/tor/torrc

HiddenServiceDir /var/lib/tor/hiddenservice/
HiddenServicePort 80 10.152.152.11:80
I think either i need to add more than 2 lines, which i dont know or something wrong with port no


#4

Is there someway where we can get paid, instant & assured support on whonix related subjects. A monthly subscription & in return we can directly chat with an expert about problems we are facing


#5

I see your problem! ALWAYS COPY/PASTE when possible!

vs.

HiddenServiceDir /var/lib/tor/hidden_service/


https://www.whonix.org/wiki/Support#Professional_Support


#6

Hi entr0py,
I checked & rechecked but thats not the problem, i added this to torrc file HiddenServiceDir /var/lib/tor/hidden_service/ & i m following instructions at https://www.whonix.org/wiki/Hidden_Services#Whonix-Gateway1 but still unable to generate Tor Hidden service url using the following command
sudo cat /var/lib/tor/hiddenservice/hostname results in No such file or directory


#7

You missed another underscore _.

sudo cat /var/lib/tor/hidden_service/hostname

Please make really sure you are really always using copy and paste.


#8

Hi Patrick,
I only copy paste the code in terminal & used “sudo cat /var/lib/tor/hidden_service/hostname” instead of “sudo cat /var/lib/tor/hiddenservice/hostname”. I login & access forum outside of whonix as its my real identity & as its designed not to copy/paste the code outside of whonix so i punch the code manually on forum, hence the mistake

I added these 2 files as per the tutotial -
HiddenServiceDir /var/lib/tor/hidden_service/
HiddenServicePort 80 10.152.152.11:80
Than
sudo service tor reload returns Warning: Unit file of tor.service changed on disk, 'systemctl daemon-reload’recommended
Than
sudo service tor status returns Active: active (exited) since…
Than
sudo cat /var/lib/tor/hidden_service/hostname returns No such file or directory

I also tried debugging used it before the last command
sudo -u debian-tor tor --verify-config returns sudo: unknown user: debian-tor sudo:unable to initialize policy plugin

Please help i’m stuck on this simple step since 3 days


#9

It is sudo service tor@default .... Not just tor. Was a recent change by the Tor package. Documentation was not update to date. Sorry about that.

You probably run the command in the workstation which is supposed to be run on the gateway.

While we are at that… This may also be the reason… Make sure you apply the commands in the component suggested by documentation. /etc/tor/torrc edits always on Whonix-Gateway.


#10

Hi Patrick,
Thank for the quick reply & apologies for making such a silly mistake (As you guessed, i was running all commands in workstation than gateway)

It is sudo service tor@default … Not just tor. Was a recent change by the Tor package. Documentation was not update to date. Sorry about that

Is it to be used in place of sudo service tor reload or sudo service tor status ?
I tried in both the places but still can’t generate hidden service url, is it a full command ?


#11

Yes.

I recommend to start with Debian jessie and the tor package. For learning. Set up a test hidden service there using plain Tor documentation. Not involving Whonix for now. Then things should become more clear. And then easily replicated on Whonix.


#12

i recommend to start with Debian jessie and the tor package. For learning. Set up a test hidden service there using plain Tor documentation. Not involving Whonix for now. Then things should become more clear. And then easily replicated on Whonix.

I m extremely sorry to bother you again & again but how to start in debain jessie or tor package? i googled the above lines but what i m getting is entirely different ways to do that & definitely not any easier than doing it on whonix also i have a mac & don’t have a machine for Debian


#13

Hi,
I tried using Graphical whonix-Gateway Steps
Start menu -> Applications -> Settings -> /etc/tor/torrc

but when i click settings (i get) -> system settings -> Common Appearance & Behavior (so on)
/etc/tor/torrc is not available there but sub folders of system settings are present

What to do ? please help


#14

If the graphical instructions don’t work, try the terminal? I have a Whonix-12 Virtualbox installation somewhere but it’s not handy… Many users have transitioned to Qubes so may not be able to tell you exactly what to do in Virtualbox on short notice.

This is pretty basic stuff. If you’re stumbling here and unable to resolve yourself, I anticipate that you might need a lot of help going forward. Not trying to be a dick, it was your idea, not mine:
https://www.whonix.org/wiki/Support#Professional_Support
(If you’ve already signed up, then I’ll let myself out.)


#15

Hi entr0py,

I have tried terminal (pls check my post above) but its not working through ways suggested & i have already contacted paid support but yet to receive an answer, so waiting for it


#16

I thought it wasn’t working because you were running the commands on your Workstation. Did you copy/paste them to your Gateway? Like I said, I was able to generate an .onion address by following the steps exactly as they are laid out. In fact, I did it offline. If you don’t hear back sooner, I’ll try it on my Virtualbox setup in a day or two.

Good to hear. The Patrick needs to be fed.


#17

Yes i was initially doing it on workstation but after being pointed out i tried it on gateway but still couldn’t create hidden url


#18

I just replied. Actually I am unsure of the business model for https://www.whonix.org/wiki/Support#Professional_Support. I compared with readhat, Debian consultants etc.

https://www.debian.org/consultants/

Fixing such basic issues would likely require VNC. So perhaps some hourly rate. I am pretty certain, only companies and wealthy exceptions would be able to afford it.


Professional Support Idea
#19

Finally it worked with sudo service tor@default reload & sudo service tor@default status