[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

had to enable community templates to get new template

Just reporting this as it says to. I had to enable Qubes Community Templates in order to install the new qubes-template-whonix-gw-16

Hello, thank you for the report!

Qubes R4.0 or R4.1?

Qubes R4.1: → https://github.com/QubesOS/qubes-issues/issues/6890 + https://github.com/QubesOS/qubes-issues/issues/6924

Did you previously disable Qubes Community Templates Repository in file /etc/yum.repos.d/qubes-templates.repo?

It should be enabled by default?

Did you previously select Qubes-Whonix being installed during Qubes installer?

I wonder how this can happen.

//cc @marmarek

Did you previously disable Qubes Community Templates Repository in file /etc/yum.repos.d/qubes-templates.repo?

It should be enabled by default?

On two different fresh installs of R4.1 beta (updated to current
stable), it’s showing as disabled by default. Want me to submit a
documentation change, or is it due to be addressed soon in code?

R4.0 - i had done a fresh install earlier this year

No, I’m 99% sure I did not disable it before.

I don’t remember if I had selected Qubes-Whonix to be installed. Since I was restoring a system I may not have, as I was I had existing Whonix qubes that I restored.

Not that I know. Solution would be…

…because salt would take care of enabling Qubes Community Templates repository in combination with…

…because not using salt exclusively in documentation yet but the “optional” qubes-dom0-update because without a download progress indicator usability is too bad. User won’t know if it takes a few hours or is completely frozen.

Then at this point I can only link to
https://github.com/QubesOS/qubes-issues/issues/6890 + https://github.com/QubesOS/qubes-issues/issues/6924

Not duplicating here since it might be outdated in future. Best to refer to these ticket for status.

How would that look? Replace

sudo qubes-dom0-update qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

with

sudo qubes-dom0-update --enablerepo=qubes-templates-community qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

?

I wanted to avoid this since users cannot copy from VM to dom0 which makes it even harder to manually type everything correctly in Qubes dom0.

I see.

After restoration, you’d loose salt settings. That’s a Qubes issue. Unrelated to Qubes-Whonix but is affected.

Patrick via Whonix Forum:

 sudo qubes-dom0-update --enablerepo=qubes-templates-community 

qubes-template-whonix-gw-16 qubes-template-whonix-ws-16

?

I wanted to avoid this since users cannot copy from VM to dom0 which
makes it even harder to manually type everything correctly in Qubes dom0.

Makes sense. How about a note to enable the repo in
‘/etc/yum.repos.d/qubes-dom0.repo’ if the command can’t find the
template? I checked your links, but didn’t see a mention of changing the
default setting.

1 Like

Not sure. Instructions are lengthy, have bad usability already. (https://github.com/QubesOS/qubes-issues/issues/6948)

It’s mentioned in the footnotes but also a complicated process since it requires editing a file with a terminal based editor (nano) which is also a challenge for users. Hence moved only in the footnotes.

Typing --enablerepo=qubes-templates-community is also cumbersome but I guess easier than requiring editing a file in dom0.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]