[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Gests GUI not showing after installing

Hey there guys, not a linux expert so I just followed the official KVM guide to the letter and during the installation I got one or two problems. When I issued

sudo addgroup “$(whoami)” libvirt

I get

addgroup: The group `libvirt’ does not exist.

Also when issuing

virsh -c qemu:///system net-start default

I get

error: Failed to start network default
error: Requested operation is not valid: network is already active

Though I guess those last two lines are more of a benign warning…

But after completing the whole process and getting two huge qemu images (107GB each), when I go and launch the machines, virtual machine manager asked for permission to install qemu-system, and then I get this:

Cannot display graphical console type ‘spice’: No module named SpiceClientGtk

On both of them, so is there a package missing or something? BTW I’m running Ubuntu Mate (The distro, not ubuntu with mate installed) 14.04 x64

Thanks in advance for any help, I guess I’ll try out the virtualbox version for a while.

The first two errors are benign and caused by differences in Ubuntu. Normally spicegtk is included in the qemu-kvm metapackage so you have a broken dependency. Try searching for spice in your software manager and install it manually and it should work.

The Whonix images are sparse files and occupy 2 GB total. The number you see is the maximum size the virtual disk can grow to. Be careful transferring the virtual disks or they will explode into the full size. For this read the wiki instructions.

No luck. After installing spice, still the same problem. I can create and sucessfully execute other virtual machines, but the whonix ones don’t show anything on screen.

When I downloaded the images, they occupied a couple Gb, but once I began extracting them, their size skyrocketed xD I ended up sticking to Virtualbox.

Did you extract the images as per https://www.whonix.org/wiki/KVM#Decompress?

Did you extract them using tar?

Did you move or copy the files? If you copied the files, did you add the parameter --sparse=always as per https://www.whonix.org/wiki/KVM#Moving_Whonix_Image_Files?

Also read this:


Post the output of the du -h command mentioned on that page here.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]