[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Gateway tor problem latest update


#9

Please post your folder permissions.

sudo ls -la /var/lib/tor

And.

sudo ls -la /var/lib/tor/hidden_service

#10

First image:
you got a typo.

Wrong:

HiddenSerivceDir

Correct your torrc to:

HiddenServiceDir

Second image:
Please post your folder permissions as requested in my previous post.


#11

Ok I’ll do that now one second.

These ss are from my host machine I quickly took the pic and noticed the typo after I posted it, It makes no difference though that is not causing the issue, I corrected it and of course and re-uploaded a new screenshot, the issue is also persistent on my vps and dedicated server too.

I will do as you requested now and edit this reply one moment


#12

Any AppArmor denied messages?

sudo grep DENIED /var/log/syslog

#13

Same error if you manually run that command?

sudo -u debian-tor tor --verify-config

#14

I guess not. And if not… It’s a whonixcheck AppArmor bug since it has no permission to read /var/lib/tor/hidden_service.


#15

Ok I ran both commands here is the results.

&


#16

Bug confirmed. Working on a fix.


#17

You’re the man thank you.


#18

#19

whonixcheck_4.6.4-1_all.deb is now available for testers from Whonix jessie-proposed-updates and testers repository suites.


#20

I have a similar issue and i checked /etc/apparmor.d/usr.bin.whonixchech is already fixed.here is a screenshot of the error: basically I was messing around with hidden service and i think i messed up the permissions for /var/lib/tor/.tor.


#21

If you just need to change ownership back,
sudo chown -R debian-tor:debian-tor /var/lib/tor


#22

drw—S--- 2 debian-tor debian-tor 4096 Nov 27 23:46 .
drwxr-xr-x 46 root root 4096 Nov 20 09:48 …
-rw------- 1 debian-tor debian-tor 18209 Nov 27 23:27 cached-certs
-rw------- 1 debian-tor debian-tor 1996740 Nov 27 23:27 cached-microdesc-consensus
-rw------- 1 debian-tor debian-tor 998190 Nov 27 23:45 cached-microdescs
-rw------- 1 debian-tor debian-tor 0 Nov 27 23:45 cached-microdescs.new
-rw------- 1 debian-tor debian-tor 0 Nov 27 23:15 lock
-rw------- 1 debian-tor debian-tor 6569 Nov 27 23:46 state


#23

No


#24

Same error if you manually run that command?
Yes.


#25

Did you make changes to /etc/tor/torrc?

Whonixcheck is looking for a directory /var/lib/tor/.tor which doesn’t exist.


#26

I changed the owner to root then back to debian-tor and I was able to start tor but I get this error now when doing whonixcheck.


#27

Strange… does echo $(timedatectl) work?

I’m reluctant to spend time troubleshooting this because

  1. it’s a unique config issue (so limited benefit to others)
  2. you don’t remember exactly what changes you’ve made (otherwise, you would reverse them and not need any help)

If you have a clean snapshot, get what you need, and revert the VM. You should always make a clean snapshot after initial install. And it’s always a good idea to clone the VM before tinkering.

If you absoutely need to salvage this instance, then we can try to troubleshoot further.


whonixcheck script bug 12/2017
#28

It’s used here.

Try running manually in a terminal.

timedatectl ; echo $?