Gateway not running tor in general

Upon freshly installing the gateway for a second time I receive an error

Something is wong with torrc! when I attempt to enable tor.

Then I receive “sudo service tor status” returned non-zero exit code, which means Tor does NOT work.

When I listen to the advice in the setup wizard I get:

My current settings for the VM’s networking is:

With all other settings default, could anyone please help me get it working? Thank you.

You’re not supposed to change network settings in VirtualBox. (Security Guide - Whonix)
They work as is by default.

I guess it’s easiest to delete that VM and to import a fresh Whonix-Gateway.

For further debugging of torrc also try this.

sudo -u debian-tor tor --verify-config

Ok upon fresh installing the network settings is NAT and second panel is internal (default settings for everything)

But I still am given this error when even installing. I’ll try the command you commented once the VM boots.

sudo -u debian-tor tor --verify-config

Did nothing in the terminal apart from prompt for my password.

I tried going to like some of the error messages claim.

Applications -> torrc and it does not exist there.

So, did you enter it?

What’s the contents of /etc/tor/torrc? (applications -> system -> torrc)

Yeah I did enter it and nothing happened last night. But when I booted it today it setup tor and such and now all is well so far. Thank you for your support, sorry for previously being vague about certain things.

Guess I spoke too soon, after installing the tor stuff since it allowed it this time I received this error.

So did you try again as it suggested?