Gateway hangs when dealt with lots of traffic over a longer period of time

I’m having an issue using Whonix on VirtualBox.
If you attach a Workstation/other VM to the Gateway and then use a multi-threaded TCP program with lots of network bandwidth it works at start, but after around 5-6 hours it hangs the Gateway.

When I use such a program Tor uses one whole core of the CPU in top always. There is always available RAM since less than 50% is actually used.

In the hanged state - the VM doesn’t respond to any input and you have to forcibly close it.

How can I fix this? It has been an issue for past Whonix versions and still hasn’t been fixed going into the new one.

My current Gateway specs:
2 GB of RAM
2 CPU cores

1 Like

Hey, I’ve tried all of this - it seems like a separate issue connect to high performance applications running on VMs connected to the Gateway. I wouldn’t post otherwise :slight_smile:

It’s a really strange issue and I hope someone can help me find out what’s going on here. I could give someone the scenario by which they could test this out.

General VirtualBox Troubleshooting Steps in Kicksecure wiki result of each step?

1 Like

I might have skipped some information - my host system is using Windows 10 and newest version of VirtualBox. I’m 100% sure it’s a performance issue and nothing related to the environment/hardware/host OS.

  1. There should be no issues here - every other VM works good. Last night I’ve tested with Whonix Gateway and another VM connected to it and it didn’t crash without a huge network load from the other VM.

  2. Not needed - no connectivity issues - only issues regarding hanging.

  3. Already using up to date Whonix.

  4. Using latest VirtualBox.

  5. Already did.

  6. I did not use it.

  7. N/A.

  8. N/A.

  9. N/A.

  10. I would still want to run it from Windows if possible :slight_smile:

  11. No other virtualizers installed other than VirtualBox.

  12. No low RAM issues - on both the Gateway VM and the other host VM.

  13. No hardware issues - haven’t had any issues with any other VM.

  14. No RAM issues.

  15. Already mentioned - any other Linux/Windows VM works fully without issues.

  16. I’m not using Debian as host for the VM so it’s N/A.

  17. Core isolation is disabled.

1 Like

Rare similar cases in the past reported that their issues were solved by using different hardware or a different host operating system. I cannot remember any Whonix bugs which caused such issues which could be resolved by fixing something in Whonix’s own source code.

Ideas for debugging:

  1. Watch Tor Log

  2. Watch Systemd Journal Log of Current Boot

  3. Check Systemd Journal Log of Previous Boot

  4. Generic Bug Reproduction or more specifically Tor Generic Bug Reproduction might be required.