[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Freenet connection problem

Hi,
I’m completely new to Whonix. I have setup a dedicated Debian system with VirtualBox and Whonix WS and GW. Accessing Tor workes without any problems.
In the last few days I’ve tried Freenet. I’ve cloned a clean WS and followed the instructions here: https://www.whonix.org/wiki/freenet. Everything worked fine until I came to “Usage”. When I restarted the Tor Browser with http://127.0.0.1:8888 Freenet showed up indeed and I was able to do the inial configuration. But when I tried to browse to a freesite nothing happened. The number of nodes always showed 0/28 and I got a message that the Freesite could not be loaded.
What am I doing wrong? Are there further settings which are not described in the wiki? I guess the Freenet configuration was a offline thing so I would never have had a connection to it.

Thanks for your efforts
Sappire

Did you know that Freenet uses UDP connections, while Tor uses TCP? To use the Freenet client in Whonix, you will have to Tunnel UDP over Tor. You might have overlooked that.

2 Likes

You need to tunnel it thru a VPN for it to connect. It does say that on the wiki.

1 Like

Sorry, I couldn’t answer earlier. I overlooked the tunneling of Tor mentioned at the beginning of the WIKI.
I’m going to catch up on this next week (holidays). Doesn’t seem to be easy. On the other hand Freenet isn’t so much important to me.
Thanks again.
Sappire

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]