[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

forums.whonix.org broken on Safest settings

Hello something is wrong with Tor Browser and I think particurarly NoScript. When I visit forums dot whonix dot org on Tor Browser with slider on “Safest” I can only see:
[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]
But when I disable javascript in about:config (“javascript.enabled” to “false”) it works as it should, I see threads and so on. duckduckgo dot com doesn’t make redirect as it should and there are no listings, site is too broken.
It’s not Whonix exclusive (it happened on Windows virtual machine) but I think it’s worth posting here (I’m Whonix user.) I posted about this problem on #tor IRC but no one really acknowledged it. Sorry if I post in the wrong category.

I am experiencing the same problem. I think NoScript version 11.2 is working fine. The problem occurs after automatic NoScript update to 11.2.1 or 11.2.2

Manually setting javascript.enabled to false in about:config seems to solve the problem.

Unsupported.

Not sure this forum thread is a duplicate but very much related to this existing discussion:

No, it’s not a duplicate. I understand that javascript is required to sign up.
But after NoScript update to 11.2.1 or 11.2.2 all sites are completely broken (on Safest settings), not only forums Whonix org. Whole page content is not visible.
Setting javascript.enabled to false in about:config solve the issue.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]