[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Failed to start Load AppArmor profiles conflict system_tor and snowflake-client

Hi. I have a problem when load Whonix-Gateway-XFCE

What I need to do to fix this?

journalctl --unit apparmor.service

Sep 02 22:24:21 host systemd[1]: Starting Load AppArmor profiles…

Sep 02 22:24:21 host apparmor.systemd[248]: Restarting AppArmor

Sep 02 22:24:21 host apparmor.systemd[248]: Reloading AppArmor profiles

Sep 02 22:24:21 host apparmor.systemd[317]: profile system_tor: has merged rule /rw/usr/bin/snowflake-client with conflicting x modif>

Sep 02 22:24:21 host apparmor.systemd[317]: ERROR merging rules for profile system_tor, failed to load

Sep 02 22:24:21 host apparmor.systemd[368]: profile system_tor: has merged rule /rw/usr/bin/snowflake-client with conflicting x modif>

Sep 02 22:24:21 host apparmor.systemd[368]: ERROR merging rules for profile system_tor, failed to load

Sep 02 22:24:21 host apparmor.systemd[248]: Error: At least one profile failed to load

Sep 02 22:24:21 host systemd[1]: apparmor.service: Main process exited, code=exited, status=1/FAILURE

Sep 02 22:24:21 host systemd[1]: apparmor.service: Failed with result ‘exit-code’.

Sep 02 22:24:21 host systemd[1]: Failed to start Load AppArmor profiles.

Update / reboot.

I tried it, it doesn’t help :frowning:

Try again.

I find solution!!!

only need change
/usr/bin/snowflake-client Pix to /usr/bin/snowflake-client ix
in file /etc/apparmor.d/abstractions/tor

And all works :slight_smile:

The question is why don’t you have the update which is already doing that.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]