[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Errors upgrading Qubes-Whonix Workstation to 15 (gnutls_handshake() failed) Can't Upgrade

root@host:/home/user# apt-get-noninteractive dist-upgrade --no-install-recommends

As it says in the tutorial I enter the code above and then I get TONS of these error messages after

99% [Working]

since I got the errors before and now every time I try to upgrade

The error messages are like:

Err:2 [ https ://deb.qubes-os dot org/r4.0/vm ](https ://deb.qubes-os dot org/r4.0/vm) buster/main amd64 pulseaudio-qubes amd64 4.0.24-1+deb10u1

gnutls_handshake() failed: The TLS connection was non-properly terminated.

Anyone have an idea on how to fix this? I can’t reinstall for whatever reason (another error in Dom0).

Thanks

(Edited to remove links so the space in front of https and the dot is added by me, and I also posted this to the Whonix subreddit)

I think you happened to be upgrading in a bad day for Qubes repos:

https://groups.google.com/forum/#!topic/qubes-devel/UcMtPj0i3uM

So the issue as i have tested now resolved. (use Qubes clearnet repo (default) if you didnt change to the onion repo)

1 Like

If the issue is transient, it can be safely ignored.

As per: