[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Errors during initial update

I just installed the latest Whonix templates (I presume these are the Whonix 11 release). But when updating with apt I saw a number of serious-sounding errors. I’m attaching the output for the updates, and would like to know if the errors can be ignored or if they need resolution.

Thanks!

PS - Seems I can’t add attachments, so here are links instead:

http://pastebin.com/8sdZPyMk
http://pastebin.com/KEe6rETB

That’s what I had to do also with my regular debian template. I assumed the problem would be fixed before the new Whonix release.

No. It will be fixed once a Whonix release build upon Qubes Q3 final will be build.

Since you’re using the testers repository already (thanks!), please also consider to enable the Qubes jessie-testing repository also. The qubes-core-agent there has this bug fixed.

[quote=“Patrick, post:4, topic:1397”]No. It will be fixed once a Whonix release build upon Qubes Q3 final will be build.

Since you’re using the testers repository already (thanks!), please also consider to enable the Qubes jessie-testing repository also. The qubes-core-agent there has this bug fixed.[/quote]

OK, I will do that. Thanks!

Now I’m having problems with the gw template. When I just did an ‘apt-get update’ it fetched repodata fairly quickly, but just afterward it runs like molasses “Reading package lists…” is advancing about 1% every 40-60 seconds.

If I disable “Jessie testing (Main)” and “Testers (main)” in the Package Sources app, it gets about 2x faster but that’s still rather slow. I think something got misconfigured in apt.

I have to do update before dist-upgrade. Its during update that it gets freakishly slow. The whole VM lurches badly (typing is very slow) while it runs.

If I switch back to the 3.19 kernel, it works at normal speed again.

With 3.18 I noticed the apparmor module is loaded (IOW built-in) but apparently disabled according to a message in dmesg. (Note, I removed the qvmpref options to enable it.) With 3.19 there is no mention of apparmor in dmesg. I’m wondering if my foray with apparmor has anything to do with the apt slowdown.

I’ll try removing the 3.19 unstable kernel and installing the stable one. Hopefully it will resolve the apt issue(?) and prevent other problems. I’m not even sure how the unstable one got there… I must have been desperate to get something to work soon after the Qubes install.

There’s no stable 3.19 to be had :slight_smile: But – Lo!! After removing the 3.19.3 pv kernel, apt-get update under 3.18.17 works perfectly fine now. Seriously, I do not know why.

@Coolout
To clarify – The vms didn’t work right even under 3.18, until I removed 3.19 from the system. I triple-checked to make sure changes I made (e.g. enabling apparmor) were disabled and the vms had been rebooted several times. Still, the vms behaved badly (apt-get update) until 3.19 guest was removed.

To both of your questions: Yes. And I’m using the default 3.19 kernel in dom0. Install was done from a 16gb stick.

I would have to guess your issue was related to actual Tor traffic rather than OS configuration issues.

Tor enabled popup has now a separate thread:
https://www.whonix.org/forum/index.php/topic,1715.0.html

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]