[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Enabling Wifi within the Safer OS Guide.

Hi Folks…

So have made my way through the ‘A Beginner Friendly Comprehensive Guide to Installing and Using a Safer Anonymous Operating System’, all setup and running fine.

Whilst following the guide, i stayed with the advice of running ethernet connection only, however after installing kali, i require the use of a wireless adapter now. My build in adapter wouldnt suffice, and so i purchased a USB Adapter, a TP Link AC1200 which is linux compatible, and has the necessary chipset required for use within Kali.

Now i made an assumption (uh oh), that before i began attempting to install the device for use with Kali i convinced myself i would have to setup the adapter on Debian first…was i correct to assume this is my host OS?

I have gathered info from the web to attempt to do this by myself, and i have tried the following…and please bear in mind i am new to Linux/Whonix…

  1. ran lsusb, my wifi adapter was listed as:
    Bus 001 Device 005: ID 2357:0101

ran lspci and my device wasn’t listed.

  1. Tried adding driver from repository at github.com/abperiasamy/rtl8812au
    But i get a 404 not found error from the site.

  2. ran apt-get update && apt-get install firmware-iwlwifi

Installed.

Now the truth be told, ive tried an untold many other ‘suggestions’ listed on Google, and im beginning to wonder if i’ve done more harm than good?

Should i wipe clean and start the guide OS guide all over? I’ve learned a lot and am pretty confident i can get through it without error and to solve all the problems i encountered the 5th time round (lol)

Also, is there anything within the whonix setup that perhaps doesn’t allow for wifi connection? or is it merely lack of knowledge/experience within linux?

Thanks

Good day,

So, am I correct in the assumption that you are using Kali as a Whonix-Workstation? Then yes, to pass through WLAN to the gateway, it first needs to work on the host.

No, neither is the case. Also, there is no real reason for using Ethernet over WLAN, other than maybe MAC address linkability. The guide you’ve mentioned isn’t endorsed by Whonix so we can’t tell you whether what is in there is correct or not.

To get that dongle running, you should be fine by simply following the driver installation from here on the host: http://www.tp-link.com/en/download/Archer-T4U.html#Driver

Have a nice day,

Ego

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]