Dynamically allocated storage not working

So I have a problem where I started to download the Monero blockchain but quickly realized that there would not be enough space, so in Virtual box, I increased it to 400 GB of Dynamically allocated storage but after It reached 100 GB the blockchain stopped, so I closed Whonixe but now when I try to boot up the workstation I get an error saying error only 0 GB free disk space and that the "swap-file-creator.service failed, I even created a new storage with 300GB but it still wont boot since there is no free space, why is the Dynamically allocated storage thing not working and increasing after 100gb? It says that its 400gb big on virtual box


(Whonix is based on Kicksecure.)

I did follow that guide, I did option A)* Using the VirtualBox graphical user interface (GUI):

VirtualBoxFileToolsVirtual Media Managerselect virtual hddadjust the size slider

unless I also need to do the next steps? thought that if you do option A its not necessary to do the rest. Well, either way, if I do need to do the other steps how can I open the command line when it won’t boot to the screen since the storage is already full?

(EDIT) ok so I was a bit dumb, but I realise me not doing the other steps where the problem, so I tried to boot it in live mode and it worked, then did the following steps, but I’m unsure if I did it correctly, since after I allocated the space and closed down the machine when trying to boot in normal mode it still had the same error)

You might not be able to grow the hard drive size from within the running system.

  • A) You need to boot from another medium (ISO). Or,
  • B) Recovery Mode.

Booting into into live mode for the purpose of increasing the size of the filesystem might not work because the filesystem is already mounted even if read-only.

This activity is unspecific to Whonix. This is a general Linux question. Would work the same if using Debian.

sorry for the late response, so I tried to boot in in recovery mode but unfortunately the same thing happened there where it says due to not enough space it won’t boot. I’m not sure what you mean by booting in another medium (ISO) not super tech-savvy haha but unless there is another way is it possible to just wipe the data on the storage? or move it somewhere else so I don’t lose my files? I did copy the whole storage in my files just incase.

Edit: Ok so what I have done is now re installed Whonix and this time I followed the steps and the disk was partined for the remaining space, but now that I’m once again downloading the Monero blockchain as soon as it hits the 100gb mark it just stops, I cant open or create new files as it says there is no space, I’m worried if I close down wonix now the same problem will happen as my last.

Potential Solutions Beyond Whonix! this link means “you need to find some way to make progress without depending on answers here.” Because that progress is too slow. Whonix isn’t special in this regard. It’s just a “normal” LInux / Debian.

The issue is:

I have an existing Debian based VirtualBox VM. The virtual storage space exceeded and no longer boots. How to increase the virtual disk size?

The issue is not:

Whonix something.

Documented just now:
Boot Virtual Machine from ISO instead of Virtual Hard Drive

Then most likely the size increase did not work. You need to verify the new disk size after disk size increase.

I found the problem, what I did was to create a new partition, but I had to remove it and then resize the main partition. It works great now, thank you for your help and patience.