[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

dont job whonix on qubes


#1

Whonix Check:
ERROR: Tor Bootstrap Result:
Whonixcheck gave up waiting.
Tor Circuit: not established
Bootstrapping 45 % done. Tor reports: WARN BOOTSTRAP PROGRESS=45 TAG=requesting_descriptors SUMMARY=“Asking for relay descriptors” WARNING=“Connection refused” REASON=CONNECTREFUSED COUNT=4 RECOMMENDATION=ignore HOSTID=“E267BE078D4CD144CD17F7F01F80182C98E6B479” HOSTADDR=“137.74.42.224:9001”

in Terminal with debugging: whonixcheck --debug --verbose

[ERROR] [whonixcheck] Tor Bootstrap Result:
Tor’s Control Port could not be reached!

Please report this Whonix bug!

(Technical information:)
(Code: 124)
(tor_bootstrap_timeout_type: sigterm)
(tor_bootstrap_status: Variable check_bootstrap_helper_script_output is empty.)
(check_socks_port_open_test: 22)
(Tor Circuit: not established)
++ return 0
++ EXIT_CODE=1
++ cleanup 1
++ true cleanup…
++ touch /var/run/whonixcheck/whonixcheck_done
++ sync
++ SIGNAL_TYPE=NONE
++ cd …
++ ‘[’ 1 = ‘’ ‘]’
++ ex_funct
++ ‘[’ ‘!’ NONE = NONE ‘]’
++ trap - SIGTERM
++ trap - SIGINT
++ trap - SIGUSR2
++ maybe_kill_apt_get_update
++ ‘[’ ‘’ = ‘’ ‘]’
++ return 0
++ command -v process_killer_helper
++ process_killer_helper
+++ type -t error_handler
++ ‘[’ function = function ‘]’
++ trap error_handler ERR
++ ‘[’ 12264 = ‘’ ‘]’
++ local ps_p_exit_code
++ ps_p_exit_code=0
++ ps -p 12264
++ ps_p_exit_code=1
++ true
++ ‘[’ ‘!’ 1 = 0 ‘]’
++ return 0
++ lastpid=
++ process_killer_helper
+++ type -t error_handler
++ ‘[’ function = function ‘]’
++ trap error_handler ERR
++ ‘[’ ‘’ = ‘’ ‘]’
++ return 0
++ cleanup_files
++ ‘[’ ‘’ = false ‘]’
++ ‘[’ -d /tmp/tmp.n6xgfHy2Qu ‘]’
++ rm --recursive /tmp/tmp.n6xgfHy2Qu
++ rm --force /var/run/whonixcheck/whonixcheck_running
++ rm --force /var/run/whonixcheck/whonixcheck_waiting
++ local command_v_output_exit_code
++ command_v_output_exit_code=0
++ command -v output_func
++ ‘[’ 0 = 0 ‘]’
++ local output_status_exit_code
++ output_status_exit_code=0
++ output_func_general --identifier whonixcheck --status --messagecli
++ output_func --identifier whonixcheck --status --messagecli
++ ‘[’ -n user ‘]’
++ ‘[’ ‘’ = true ‘]’
++ /usr/lib/msgcollector/msgcollector --identifier whonixcheck --whoami user --identifier whonixcheck --status --messagecli
++ return 1
++ return 1
++ output_status_exit_code=1
++ true
++ ‘[’ ‘!’ 1 = 1 ‘]’
++ ‘[’ ‘!’ ‘’ = ‘’ ‘]’
++ ‘[’ NONE = SIGUSR2 ‘]’
++ ‘[’ ‘’ = 0 ‘]’
++ true ‘No progress bar open. No need to send progress 100 to close progress bar.’
++ ‘[’ ‘whonixcheck | Whonix-Gateway | whonix-gw Template-Based ProxyVM’ = ‘’ ‘]’
++ ‘[’ ‘sys-whonix | Whonix-Gateway | whonix-gw Template-Based ProxyVM | Sun Mar 11 18:57:00 UTC 2018’ = ‘’ ‘]’
++ true --titlex ‘whonixcheck | Whonix-Gateway | whonix-gw Template-Based ProxyVM’
++ output_func_cli --titlecli ‘sys-whonix | Whonix-Gateway | whonix-gw Template-Based ProxyVM | Sun Mar 11 18:57:00 UTC 2018’
++ ‘[’ ‘’ = true ‘]’
++ true ‘output_func_cli: injecting --onlyecho.’
++ output_func --onlyecho --titlecli ‘sys-whonix | Whonix-Gateway | whonix-gw Template-Based ProxyVM | Sun Mar 11 18:57:00 UTC 2018’
++ ‘[’ -n user ‘]’
++ ‘[’ ‘’ = true ‘]’
++ /usr/lib/msgcollector/msgcollector --identifier whonixcheck --whoami user --onlyecho --titlecli ‘sys-whonix | Whonix-Gateway | whonix-gw Template-Based ProxyVM | Sun Mar 11 18:57:00 UTC 2018’
++ return 0
++ ‘[’ ‘!’ NONE = NONE ‘]’
++ true --messagex --done
++ output_func_cli --messagecli --done
++ ‘[’ ‘’ = true ‘]’
++ true ‘output_func_cli: injecting --onlyecho.’
++ output_func --onlyecho --messagecli --done
++ ‘[’ -n user ‘]’
++ ‘[’ ‘’ = true ‘]’
++ /usr/lib/msgcollector/msgcollector --identifier whonixcheck --whoami user --onlyecho --messagecli --done
++ return 0
++ ‘[’ 1 = ‘’ ‘]’
++ exit 1

Through a firewall any virtual machine works with tor browser. whonix refuses to work even after reinstallation.


#2

Hi tartuf

Is your firewall blocking Whonix?

  • Could you try configuring Whonix to bypassing your firewall and connect directly to sys-net. Do you have connectivity now?

If you still have no connection:

  • Can you post the output of anything of interest in your Tor logs. (be sure to redact any sensitive information

    tail -f /var/run/tor/log

    Alternately you can use Arm Tor controller.

  • Are you using a bridge or VPN with Whonix?

Another possibility is the time in sys-whonix is incorrect. (necessary to connect to Tor) If this is the case you will have to set time in sys-whonix manually.

https://whonix.org/wiki/Troubleshooting#Clock_Fix

Use this site as reference to set UTC time:

https://timeanddate.com/worldclock/timezone/utc


#3

on a nearby computer everything costs and works. Time on virtual machines with the same difference on both computers.
I tried to set the time in different ways. I assure you, all the options are exhausted.
when sys-whonix is ​​running, in its ARM console very rarely there are times when the connection is long in 1-2 seconds. then again silence 1-3 minutes.

I removed whonix-gw and installed it again. then deleted the old sys-whonix and created a new one. all acting through dom0.
now I get the following message:

ERROR: Tor Bootstrap Result:
Whonixcheck gave up waiting.
Tor Circuit: not established
Bootstrapping 25 % done. Tor reports: NOTICE BOOTSTRAP PROGRESS=25 TAG=loading_status SUMMARY=“Loading networkstatus consensus”


#4

it’s decided!

before the beginning of all problems was the update of the virtual machines sys-net and sys-firewall through the console command “sudo apt-get update”.
removed sys-net and sys-firewall and installed them again.


#5

I’ve seen this in the past related to regenerating the Tor state file or not using Tor for extended periods, and having a snail like pace when downloading the Tor network status consensus (several Mb from memory - 6/7 Mb?).

Eventually it bootstraps (an hour or so later), and then Tor connections seem lightning fast thereafter.