[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

DispVM Whonix WS creation


#1

Hi,

I seem to be having a similar problem that Patrick posted here & in qubes-issues when creating a whonix disposableVM. I always get:

Failed to save to domain whonix-ws-dvm to /var/lib…
error: internal error: Failed to save domain ‘xx’ with libxenlight

The strange thing is that if I try to create a non-whonix-based dispvm - even straight after this error - it works. It only fails for my whonix-ws & any other whonix based template.

I am trying this on a laptop with only 4GB RAM - on my own laptop what has 12GB - it works. But as I said - if it was a memory issue - why does it work for any non-whonix based template?

Seems strange.

Patrick - you seems to have the same error before - did you overcome it??


#2

This actually belongs to the Qubes help channels, because the issue is happening in dom0, not inside Qubes-Whonix.


#3

If I understand it correctly, it is probably a low memory error. See here - although this was ‘starting’ not ‘creating’ dispVM I think (?):

So, based on Marek’s advice and Patrick’s eventual successful DispVM generation, you could probably:

a) First try shutting down every VM that is not needed before creation of the DispVM i.e. all of them before this step in dom0:

qvm-create-default-dvm whonix-ws

b) If that doesn’t work, try leaving the laptop idle for a period of time before re-trying, since that appears to have worked for Patrick (?)

4GB is not a lot of memory for Qubes. If you have sys-net, sys-firewall, sys-whonix, dom-0 and sys-usb running already, then understandably the system is probably on the verge of dying with a couple more VMs. But yeah, strange if a standard DispVM works.

Qubes should probably be run with 12-16 GB as desirable, with 8GB the bare minimum for normal functional use, even though the docs say 4 GB is okay.


#4

I’ll try on the Qubes mailing list (I wish they had a forum!!).

Torjunkie - there’s another 8GB on order to add to the 4GB - it’s a colleague’s laptop actually, I run Qubes with 12GB without any problems. The strange thing is - the 4GB laptop can create a dvm from any other non-whonix template - even a very large customised fedora-24 template that’s 2x the size of whonix-ws.


#5

Just to update - as soon as I updated the RAM from 4GB to 8GB - the whonix DispVM was created without any problem.

But it’s strange that larger templates could be used for dispvms with only 4GB.

Anyway - it’s working fine now.